libmoveit_robot_model.so.0.9.11: cannot open shared object file: No such file or directory

asked 2018-06-14 11:55:07 -0500

lexalenka gravatar image

updated 2018-06-14 18:10:08 -0500

Hello, I'm trying to run the ros simulator (which previously worked on my system) but I'm getting an error stating that libmoveit_robot_model.so.0.9.11 can't be found; I'll attach the full message below. I've searched the internet for a quick 'apt-get install x' fix, but I have been unsuccessful in finding a fix.

Here's a list of installed & updated packages:

        ros-kinetic-desktop \
        ros-kinetic-rviz-visual-tools \
        ros-kinetic-moveit-core \
        ros-kinetic-rosparam-shortcuts \
        python-catkin-tools \
        terminator \

I've tried re-installing multiple times using the commands :

wget https://raw.githubusercontent.com/oroca/oroca-ros-pkg/master/ros_install.sh && chmod 755 ./ros_install.sh && ./ros_install.sh catkin_ws_oroca indigo

as well as

curl https://raw.githubusercontent.com/oroca/oroca-ros-pkg/master/ros_install.sh | bash -s cws_oroca kinetic

I've also updated my ubuntu 16.04 system multiple times. libx_rviz_robot_state_rviz_plugin.so does exist in the mentioned location. Below is the error summary when I try to run:

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.13

NODES
  /
    dummy_tf (tf/static_transform_publisher)
    rviz (rviz/rviz)

auto-starting new master
process[master]: started with pid [21031]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to b087693a-6ff2-11e8-9ac0-40a3ccf100f9
process[rosout-1]: started with pid [21044]
started core service [/rosout]
process[dummy_tf-2]: started with pid [21048]
process[rviz-3]: started with pid [21062]
[ INFO] [1528994877.411283956]: rviz version 1.12.16
[ INFO] [1528994877.411314694]: compiled against Qt version 5.5.1
[ INFO] [1528994877.411323719]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1528994878.233878431]: Stereo is NOT SUPPORTED
[ INFO] [1528994878.233999337]: OpenGl version: 4.5 (GLSL 4.5).
[ERROR] [1528994878.293648841]: PluginlibFactory: The plugin for class 'robot_state_rviz_plugin/xRobotState' failed to load.  Error: Failed to load library /home/x/x/ros/devel/lib/libx_rviz_robot_state_rviz_plugin.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = libmoveit_robot_model.so.0.9.11: cannot open shared object file: No such file or directory)
edit retag flag offensive close merge delete

Comments

1

I don't know about oroca, but this error indicates that you've updated MoveIt, but haven't recompiled some of the other packages that depend on MoveIt. Versioning of shared libs (.so.X.Y.Z) was introduced by MoveIt devs exactly for this reason: MoveIt was upgraded in a non-bw-compatible way, ..

gvdhoorn gravatar imagegvdhoorn ( 2018-06-14 12:30:45 -0500 )edit

.. and in order to avoid 'silent' errors or hard to diagnose SEGFAULTs, changing the name of the libraries breaks applications on purpose.

You'll have to remove/recompile the oroca components that are now failing to load. That would seem to include verb_rviz_robot_state_rviz_plugin.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-14 12:32:02 -0500 )edit

ok could you point me to a location that explains to do that or give the commands (to both of the comments)

lexalenka gravatar imagelexalenka ( 2018-06-14 12:40:16 -0500 )edit

Give commands for what? I don't have any experience with oroca, so I wouldn't know what to tell you.

I would recommend you try and ask oroca devs/maintainers how to rebuild / reinstall their application(s), particularly oroca-ros-pkg.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-14 12:43:26 -0500 )edit

Thanks, just giving me the oroca-ros-pkg name is helpful. Will try now.

Trying to just remove then reinstall: E: Unable to locate package oroca-ros-pkg

lexalenka gravatar imagelexalenka ( 2018-06-14 12:45:28 -0500 )edit

oroca-ros-pkg is the name of the repository on the oroca github organisation. Not a debian / ubuntu pkg name.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-14 12:48:54 -0500 )edit

got it, following whats available from https://github.com/oroca/oroca-ros-pkg

I've tried recompiling the MoveIt related packages and updating the aforementioned packages above. I know this is a long shot, but is there a simple list somewhere of all intended packages?

lexalenka gravatar imagelexalenka ( 2018-06-14 12:50:48 -0500 )edit

For reference I'm following these instructions: http://wiki.ros.org/kinetic/Installat...

and even purging then reinstalling results in the same error

lexalenka gravatar imagelexalenka ( 2018-06-14 13:03:50 -0500 )edit