Ask Your Question
1 Error

asked 2018-05-31 07:11:01 -0500

Kashyap.m94 gravatar image


I was going through the Moveit tutorials here: Moveit Commander Scripting and when I tried launching rosrun moveit_commander, I am getting the following error:

kashyap@kashyap-Lenovo-ideapad-320-15IKB:~$ rosrun moveit_commander
Failed to import pyassimp, see for more info
Traceback (most recent call last):
  File "/home/kashyap/catkin_ws/src/moveit/moveit_commander/bin/", line 156, in <module>
  File "/home/kashyap/catkin_ws/src/moveit/moveit_commander/bin/", line 81, in run_interactive
    c = MoveGroupCommandInterpreter()
  File "/home/kashyap/catkin_ws/src/moveit/moveit_commander/src/moveit_commander/", line 64, in __init__
    self._planning_scene_interface = PlanningSceneInterface()
  File "/home/kashyap/catkin_ws/src/moveit/moveit_commander/src/moveit_commander/", line 62, in __init__
    self._psi = _moveit_planning_scene_interface.PlanningSceneInterface()
Boost.Python.ArgumentError: Python argument types in
did not match C++ signature:
    __init__(_object*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)

Could anyone guide me as to what this error means? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2018-05-31 13:59:05 -0500

gvdhoorn gravatar image

This is a known problem, and there is already a PR to fix it: ros-planning/moveit#929.

edit flag offensive delete link more


Thanks, the fix worked

Kashyap.m94 gravatar image Kashyap.m94  ( 2018-06-04 10:22:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2018-05-31 07:11:01 -0500

Seen: 531 times

Last updated: May 31 '18