Ask Your Question
0

Cannot run ros_qt_gui_pkg using upstart package

asked 2018-05-29 20:47:48 -0500

jo gravatar image

I try so many way to run ros_qt_gui_pkg at boot. This package using GUI. But they didn't work.

I tried to run package at boot using robot_upstart pkg but there is only package cannot to connect X server.

Also I tried another package, not using GUI, they perfectly work.

I want to run ros_qt_gui_pkg at boot.

Then, In this case, What Can I do ?

edit retag flag offensive close merge delete

Comments

I suggested in #q292621 that you put together your questions on a single question #q290765 since info on these 2 questions seem to consist of one question.

130s gravatar image 130s  ( 2018-05-30 11:39:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-11 19:35:21 -0500

Khalaf90 gravatar image

for GUI node you need to adjust the service generate by robot_upstart and add : set Environment=DISPLAY=:0

I wrote my experience at

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-29 20:47:48 -0500

Seen: 51 times

Last updated: Apr 11