Ask Your Question
0

rqt plugin not listed

asked 2018-05-25 10:57:43 -0600

Vinni gravatar image

updated 2018-05-25 11:22:11 -0600

Hi,

I tried everything mentioned in other posts and I still can't see my own plugin in rqt. I did --force-discover, I deleted the config file but it won't show.

I am wondering if I am missing some PATH variables or if I need to compile it differently. My plugin works when I run "rosrun gcs_gui gcs_gui". "rqt -s gcs_gui" returns that no plugin with this name was found. Any ideas?

Update: I was obviously missing the plugin.xml. But there I don't know how I need to set it up. What is my class type? I programmed the plugin in C++ but is the base_class_type rqt_gui_py::Plugin anyway? Do I need to use a python file somewhere?

Vincenz

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-25 11:25:02 -0600

Femer gravatar image

Hi Vinni,

it's rather difficult to help you without any further information. I suggest you use this (great) repo catkin_create_rqt which creates a boilerplate for an RQT GUI with properly set CMakeLists.txt and plugin export file. Then you can just copy and past your functions to the newly created boilerplate.

Regards,

Marco.

edit flag offensive delete link more

Comments

Hi Marco, that is actually how I started off (well, with catkin_create_qt_pkg). I altered my code from there but it is not running. I will try setting it up as another package and see if I can get that to work. Main problem for me is setting up the plugin.xml correctly...

Vinni gravatar image Vinni  ( 2018-05-25 11:31:30 -0600 )edit

I get a strange error like this: Failed to load nodelet [rqt_gcs/View_1] of type [rqt_gcs/View]: Could not find library corresponding to plugin rqt_gcs/View. Make sure the plugin description XML file has the correct name of the library and that the library actually...

Vinni gravatar image Vinni  ( 2018-05-25 11:51:31 -0600 )edit

Worked in the end. Great tool.

Vinni gravatar image Vinni  ( 2018-05-25 15:19:09 -0600 )edit

good to hear that it worked eventually! What was the issue?

Femer gravatar image Femer  ( 2018-05-26 04:07:53 -0600 )edit

I tried somehow merging it right away with my old files. That didn't work. Simply running the script and executing the files worked. Unfortunately my workflow is not done yet. I can't get it to work the way I'd like to... Any idea? See https://answers.ros.org/question/2923...

Vinni gravatar image Vinni  ( 2018-05-29 07:48:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-25 10:57:43 -0600

Seen: 371 times

Last updated: May 25 '18