Roslaunch cannot locate rtamap node (Kinetic/jetsontx2)

asked 2018-05-16 09:58:11 -0600

scanf30 gravatar image

updated 2018-05-16 10:01:01 -0600

I'm new in ROS and have installed rtabmap and rtamap-ros via apt in a jetsonTx2. i did a launch file with the zed wrapper, my package and the rtabmap-ros and it can not locate the node.

This is the launch file:

<?xml version="1.0"?>
    <env name="ROS_NAMESPACE" value="camera"/>
    <include file="$(find zed_wrapper)/launch/zed_camera.launch"/>
    <node name="foo" pkg="sleep_launch" type=""/> 
    <include file="/opt/ros/kinetic/share/rtabmap_ros/launch/rtabmap.launch">
        <arg name="rtabmap_args" value="--delete_db_on_start"/>
        <arg name="depth_topic" value="/camera/depth/depth_registered"/>
        <arg name="frame_id" value="zed_center"/>
        <arg name="approx_sync" value="false"/>
        <arg name="visual_odometry" value="false"/>
        <arg name="odom_topic" value="/camera/odom"/>

Then i ran the launch file without the zed_wrapper and my package and the problem still "alive". This is the terminal output:

ERROR: cannot launch node of type [rtabmap_ros/rtabmap]: can't locate node [rtabmap] in package [rtabmap_ros]
ERROR: cannot launch node of type [rtabmap_ros/rtabmapviz]: can't locate node [rtabmapviz] in package [rtabmap_ros]

when i run it like the tutorial or type in the terminal:

$rosrun rtabmap_ros rtabmap

i don't have problems.

in the last line of my .bashrc i have

source /opt/ros/kinetic/setup.bash

and in the new terminal i do:

~/foo/catkin_ws$ source devel/setup.bash
edit retag flag offensive close merge delete


in the launchfile i started whit

 <include file="$(find rtabmap_ros)/launch/rtabmap.launch">
scanf30 gravatar image scanf30  ( 2018-05-16 10:12:36 -0600 )edit