Ask Your Question
0

How enable motors in hector quadrotor?

asked 2018-05-08 01:15:55 -0600

fantaa499 gravatar image

I start gazebo simulation with command:

roslaunch hector_quadrotor_demo outdoor_flight_gazebo.launch

All works fine, but when i try write in topic /cmd_vel nothing happens. To ensure that the quadrocopter flew it was necessary to turn on the motors with the command:

rosservice call /enable_motors true

But output tell:

ERROR: Service [/enable_motors] is not available.

In the list of available services ($ rosservice list) /enable_motors is not present. How I can enable motors?

P.S. Windows Subsystem for Linux, Ubuntu 16, ROS kinetic. P.P.S. On Ubuntu everything is working.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-09 00:44:41 -0600

hamed ghasemi gravatar image

I aslso have this problem. can anyone solved? I'm using ros indigo and Ubuntu 14.04.1

Thank you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-08 01:15:55 -0600

Seen: 382 times

Last updated: May 09