Ask Your Question
0

ROS can't find rospack

asked 2012-03-03 15:05:11 -0600

commanchetruck gravatar image

updated 2012-03-03 15:07:12 -0600

When trying to use cmake with this CMakeLists:

cmake_minimum_required(VERSION 2.4.6)
include(/opt/ros/electric/ros/core/rosbuild/rosbuild.cmake)

# Set the build type.  Options are:
#  Coverage       : w/ debug symbols, w/o optimization, w/ code-coverage
#  Debug          : w/ debug symbols, w/o optimization
#  Release        : w/o debug symbols, w/ optimization
#  RelWithDebInfo : w/ debug symbols, w/ optimization
#  MinSizeRel     : w/o debug symbols, w/ optimization, stripped binaries
#set(ROS_BUILD_TYPE RelWithDebInfo)

rosbuild_init()

#set the default path for built executables to the "bin" directory
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
#set the default path for built libraries to the "lib" directory
set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)

#uncomment if you have defined messages
#rosbuild_genmsg()
#uncomment if you have defined services
#rosbuild_gensrv()

#common commands for building c++ executables and libraries
#rosbuild_add_library(${PROJECT_NAME} src/example.cpp)
#target_link_libraries(${PROJECT_NAME} another_library)
#rosbuild_add_boost_directories()
#rosbuild_link_boost(${PROJECT_NAME} thread)
#rosbuild_add_executable(example examples/example.cpp)
rosbuild_add_executable(calibration_cameras src/calibration.cpp)
#target_link_libraries(example ${PROJECT_NAME})
include_directories(/usr/include/opencv-2.3.1)

I get this error in the CMake console:

CMake Error at /opt/ros/electric/ros/core/rosbuild/rosbuild.cmake:24 (message):
  Couldn't find rospack.  Please run 'make' in $ROS_ROOT
Call Stack (most recent call first):
  CMakeLists.txt:2 (include)

Running cmake in ros root gave this error:

CMake Error at CMakeLists.txt:23 (include):
  include could not find load file:

    /core/rosbuild/rosconfig.cmake


CMake Error at CMakeLists.txt:35 (message):
  Neither shared nor static libraries are enabled.  Please set either
  ROS_BUILD_STATIC_LIBS or ROS_BUILD_SHARED_LIBS to true.

I have checked, and rosconfig.cmake is where it should be. Any help appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-03-04 03:14:15 -0600

Thomas gravatar image

It seems to me that you tried to hardcode your paths (line 2 for instance) to workaround the fact that your environment variables are not defined.

First, type "source /opt/ros/eletric/setup.bash" then remove the hard-coded paths (re-run roscreate-pkg somewhere to know how to revert your changes) and then run "make" into your package. It should work.

edit flag offensive delete link more
0

answered 2012-03-03 22:46:31 -0600

dornhege gravatar image

This should work.

Please provide information about your setup. Otherwise this is just guessing: Did you source setup.sh?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-03 15:05:11 -0600

Seen: 1,893 times

Last updated: Mar 04 '12