Bluetooth communication in ROS. Unable to setup dev/rfcomm [closed]

asked 2018-04-14 16:01:59 -0500

BhanuKiran.Chaluvadi gravatar image

updated 2018-04-14 16:04:33 -0500

Hi,

I am have Bluno nano and would like to connect it my pc and receive information via blue tooth. Unfortunately i am very new to blue tooth and sure about the exact steps. I went through few ROS answer and some online but unable to make it work.

  1. I paired Bluno nano my pc (checked via - $ bluetoothctl , [bluetooth]# paired-devices).

  2. After that i ran $ sudo rfcomm bind 0 F4:5E:AB:AA:BB:CC 1

  3. Then i tried to $ run rosrun rosserial_python serial_node.py /dev/r

when i double tap for the above command nothing is showing up for "dev/r..." .

I also tried " sudo vim /etc/bluetooth/rfcomm.conf" but rfcomm.config doesn'texist.

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by gvdhoorn
close date 2018-04-15 00:18:55.956901

Comments

I'm sorry, but this seems like purely a system configuration issue at this point. The fact that you intend to use rosserial does not change that. As we have almost 40000 questions here already, we try to stay as on-topic as possible. You might want to post this question over at AskUbuntu.

gvdhoorn gravatar imagegvdhoorn ( 2018-04-15 00:20:35 -0500 )edit