ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosserial mbed comunication does not work

asked 2018-02-15 16:39:54 -0500

Kilmulis gravatar image

updated 2018-02-16 01:41:29 -0500

gvdhoorn gravatar image

Hello, I am working on Ubuntu 16.04 and ROS Kinetic. I downloaded rosserial jade-devel since there is no branch for Kinetic. I have read that some people used it and it worked. When I am trying to connect to my STM using

rosrun rosserial_python _port:=/dev/ttyUSB0 _baud:=115200

there is an allert:

[ERROR] [1518733110.399872]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I am using mbed online compiler, I tried to change baud rate and library on compiler to both kinetic and jade mbed.

My USB-UART device is connected to ttyUSB0. Is there an official Kinetic rosserial version? Do You have any idea what should I do to fix it and make it run? Thank You for answers.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-02-16 04:19:22 -0500

thepirate16 gravatar image

updated 2018-02-16 04:20:50 -0500

rosserial_python was a bit unstable when I used it to connect an Arduino to ROS. Could you try using rosserial_server instead? That worked properly for me.

$ roslaunch rosserial_server serial.launch

You can see my question here, it might work as an example for you.

edit flag offensive delete link more

Question Tools


Asked: 2018-02-15 16:39:54 -0500

Seen: 399 times

Last updated: Feb 16 '18