[ERROR] Unable to sync with device

asked 2018-02-07 00:26:13 -0500

updated 2018-02-08 23:23:16 -0500

i have visited all the same question like this one they are #q212074 and #q221346 but it not solved my problem even relevant to my question but i have try all the tricks But still get

[ INFO] [1517983879.692596654]: Replanning: no
[ WARN] [1517983879.817263349]: Interactive marker 'EE:goal_wrist_roll_link' contains unnormalized quaternions. This warning will only be output once but may be true for others; enable DEBUG messages for ros.rviz.quaternions to see more details.
[ERROR] [1517983890.148902]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino
[INFO] [1517983890.205161]: Note: subscribe buffer size is 280 bytes
[INFO] [1517983890.206685]: Setup subscriber on joint_array [std_msgs/UInt8MultiArray] "

this error again and again .

My main Question is :- i am trying to control my own Robotic Arm with ROS and i am using Arduino board but when i connect Arduino and Run my launch file i get this Error that i have mentioned above , if anyone familiar with this type of error please help me to solve this

edit retag flag offensive close merge delete

Comments

1

Can you please update your question with all the relevant information? Right now, this question doesn't stand on its own (i.e., you don't say what you're trying to do, what you've run, how you've tried to fix it, etc.)

jayess gravatar imagejayess ( 2018-02-07 00:39:14 -0500 )edit

Thanks sir i updated may u need more information ?

lagankapoor gravatar imagelagankapoor ( 2018-02-07 00:56:46 -0500 )edit
1

What are

all the tricks

that you tried? Please be specific. We can't help if we don't know what doesn't work.

jayess gravatar imagejayess ( 2018-02-07 23:42:04 -0500 )edit

@jayess i tried to change the baud rate and even try to use serial_python node and it doesn't work

lagankapoor gravatar imagelagankapoor ( 2018-02-08 00:52:50 -0500 )edit
1

Does the baud rate that you're using to run the node using rosrun match the baud rate in your code? Are your messages too big?

jayess gravatar imagejayess ( 2018-02-08 01:00:06 -0500 )edit

@jayessi have try to match 3-4 rate but default i use 57600 but it doesn't work

lagankapoor gravatar imagelagankapoor ( 2018-02-08 01:16:40 -0500 )edit
3

@lagankapoor: I'm going to have to ask you to stop bumping your question. Your last 3 edits changed nothing, but did get your question back to the top of the question list.

If you haven't received any answers, that means either no one knows, or the ppl that could know haven't visited ROS Answers.

gvdhoorn gravatar imagegvdhoorn ( 2018-02-09 02:21:49 -0500 )edit

@gvdhoorn that's why i do that because if they come online here they check my Question but Sorry for that :(

lagankapoor gravatar imagelagankapoor ( 2018-02-09 02:23:55 -0500 )edit