ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

IOError: [Errno 13] Permission denied .ros/rosdep/sources.cache/index

asked 2018-02-01 00:18:40 -0500

MakerHanRos gravatar image

updated 2018-02-02 12:43:33 -0500

lucasw gravatar image


makerhan@makerhan-Inspiron-15-3567:~$ roslaunch turtlebot_gazebo turtlebot_world.launch
... logging to /home/makerhan/.ros/log/d3447fd4-0716-11e8-8422-44032cf50938/roslaunch-makerhan-Inspiron-15-3567-13942.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see is deprecated; please use xacro instead
started roslaunch server http://localhost:46237/


 * /bumper2pointcloud/pointcloud_radius: 0.24
 * /cmd_vel_mux/yaml_cfg_file: /opt/ros/kinetic/...
 * /depthimage_to_laserscan/output_frame_id: /camera_depth_frame
 * /depthimage_to_laserscan/range_min: 0.45
 * /depthimage_to_laserscan/scan_height: 10
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 30.0
 * /rosdistro: kinetic
 * /rosversion: 1.12.12
 * /use_sim_time: True

    bumper2pointcloud (nodelet/nodelet)
    cmd_vel_mux (nodelet/nodelet)
    depthimage_to_laserscan (nodelet/nodelet)
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)
    laserscan_nodelet_manager (nodelet/nodelet)
    mobile_base_nodelet_manager (nodelet/nodelet)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    spawn_turtlebot_model (gazebo_ros/spawn_model)


process[gazebo-1]: started with pid [13962]
process[gazebo_gui-2]: started with pid [13967]
process[spawn_turtlebot_model-3]: started with pid [13972]
process[mobile_base_nodelet_manager-4]: started with pid [13973]
process[cmd_vel_mux-5]: started with pid [13974]
process[bumper2pointcloud-6]: started with pid [13975]
process[robot_state_publisher-7]: started with pid [13976]
process[laserscan_nodelet_manager-8]: started with pid [13984]
process[depthimage_to_laserscan-9]: started with pid [13997]
[ INFO] [1517465536.132313314]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1517465536.133011067]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/gazebo_ros/spawn_model", line 32, in <module>
    import tf.transformations as tft
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/tf/", line 28, in <module>
    from tf2_ros import TransformException as Exception, ConnectivityException, LookupException, ExtrapolationException
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/tf2_ros/", line 39, in <module>
    from .buffer_interface import *
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/tf2_ros/", line 32, in <module>
    import roslib; roslib.load_manifest('tf2_ros')
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslib/", line 62, in load_manifest
    sys.path = _generate_python_path(package_name, _rospack) + sys.path
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslib/", line 93, in _generate_python_path
    m = rospack.get_manifest(pkg)
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 167, in get_manifest
    return self._load_manifest(name)
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 211, in _load_manifest
    retval = self._manifests[name] = parse_manifest_file(self.get_path(name), self._manifest_name, rospack=self)
  File "/usr/lib/python2.7/dist-packages/rospkg/", line 412, in parse_manifest_file
    _static_rosdep_view = init_rospack_interface()
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 58, in init_rospack_interface
    lookup = _get_default_RosdepLookup(Options())
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 128, in _get_default_RosdepLookup
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 613, in create_default
    sources = load_cached_sources_list(sources_cache_dir=sources_cache_dir, verbose=verbose)
  File "/usr/lib/python2.7/dist-packages/rosdep2/", line 510, in load_cached_sources_list
    with open(cache_index, 'r') as f:
**IOError: [Errno 13] Permission denied: '/home/makerhan/.ros/rosdep/sources.cache/index'
[spawn_turtlebot_model-3] process has died [pid 13972, exit code 1, cmd /opt/ros ...
edit retag flag offensive close merge delete



maybe explaing what you are trying to do? For how to properly create a question, check out

mgruhler gravatar image mgruhler  ( 2018-02-01 02:39:39 -0500 )edit

A question without a question, isn't really a question.

jayess gravatar image jayess  ( 2018-02-01 10:03:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-02-02 12:37:51 -0500

lucasw gravatar image

updated 2018-02-02 12:42:49 -0500

See if /home/makerhan/.ros/rosdep/sources.cache/index already exists, or exists but permissions are incorrect on it (maybe wrongly running sudo rosdep update creates this problem?).

If it doesn't exist try:

sudo rosdep init
rosdep update

(if it does already exist, maybe delete it first then run rosdep steps again)

I'm just guessing, maybe later I'll try deleting my own and seeing if the same error comes up and update this. looks related.

edit flag offensive delete link more


I had a similar problem (I'm pretty sure I did sudo rosdep update at somepoint last week). Doing rosdep update fixed it for me. Thanks

billqd gravatar image billqd  ( 2019-03-27 16:19:58 -0500 )edit

Question Tools



Asked: 2018-02-01 00:18:40 -0500

Seen: 20,892 times

Last updated: Feb 02 '18