Ask Your Question
0

Arduino rosserial - Unable to sync with device

asked 2018-01-16 18:44:23 -0500

Tanvir gravatar image

updated 2018-01-16 18:45:17 -0500

When I try to use the 'Hello World' program with rosserial and arduino after restarting my pc. The code works fine, however once i stop the serial communication and try to rerun the same code. I get the following error.

[INFO] [WallTime: 1399983521.604184] ROS Serial Python Node
[INFO] [WallTime: 1399983521.617853] Connecting to /dev/ttyACM0 at 57600 baud
[ERROR] [WallTime: 1399983538.726124] Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I am facing the same issue using both arduino UNO and arduino Nano. I have tried increasing the buffer size in ros.h, setting the baud rate in arduino code with Serial.begin(57600) and all the solutions mentioned in link. What else can i do to fix the problem ?

edit retag flag offensive close merge delete

Comments

1

Can you check whether you device is properly configured? If not, do this on terminal: $ ls /dev/ttyACM0 $ sudo chmod 666 /dev/ttyACM0 And then try again.

smartbot gravatar image smartbot  ( 2018-03-08 19:37:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-10-02 13:22:31 -0500

I had same issues with communicating to STM32 controller through ROS-noetic and rosserial-Mbed.

Here, the issue is with the version of the 'rosrun python'.

I installed python3 and obviously, did sudo update that fixed my problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-16 18:44:23 -0500

Seen: 552 times

Last updated: Jan 16 '18