Trouble initializing Canopen_chain_node [closed]

asked 2017-11-15 04:17:28 -0600

rhas gravatar image

updated 2017-11-15 06:59:12 -0600

I am trying to use the Canopen_chain_node but for some reason the system cannot find the node when I am trying to initialize.

I have tried to eliminate errors in my own eds and config files by trying to use different files I have found here on ros answers (ex. Here with some modifications to the config file).

My setup is that i am connected to a PEAK debugger but this isn't connected t anything as I would like to be able to run tests while away from the motors (Could this be a problem? if I use canutils' cansend I can see the message using candump so i figured I should be alright).

I then launch the chain.launch within canopen_chain_node (should this start sending messages over the canbus right away? I am seeing nothing after launching)

then i try to initialize the node calling rosservice call /driver/init . this call results in an NMT message to reset the communication, as it should (can0 000 [2] 82 01), but the node doesn't respond (should respond with can0 701 [1] 00 as it is node 1).

Am I missing a step? I have tried to look around to see if anybody has the same problem but I haven't been able to find anything yet. Any help is much appreciated.

Edit: I might have misunderstood what the canopen_chain_node actuallly does, so i have asked another question about that here. If I have misundestood how the canopen_chain_node works, this question might be obsolete. I thought/think that the canopen_chain_node "made" a local node with its own unique object dictionary that is configured via eds/dcf files and where it is possible to read and write from objects using get_object and set_object

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rhas
close date 2017-11-15 08:09:21.570508