Ask Your Question
0

how prevent rotation with teb_local_planner

asked 2017-11-08 13:05:55 -0500

pietrocolombo gravatar image

updated 2017-11-09 04:00:31 -0500

Hi, I'm using navigation stack and using teb_local_planner for path planning. I change this parameter "max_vel_x_backwards: 0.0" so the robot will not move backwards. But I also want the robot not to rotate on itself. how can I do?

Video

edit retag flag offensive close merge delete

Comments

Hello,

I am facing the same problem. I have a robot that rotates with a 1.4m radius and that is not able to perform backwards movements (or lets say that I truly prefer it doesn't due to security reasons). Did you manage to find a solution?

Thank you

JohnMdz gravatar image JohnMdz  ( 2018-06-28 11:30:43 -0500 )edit

have you tried adjusting the turning radius parameter?

aarontan gravatar image aarontan  ( 2018-06-28 11:51:24 -0500 )edit

I have. And that part seems to be working. The problem is the backward movement. My robot cannot perform backward movement. I'd be comfortable with a message from the planner saying it is impossible to find a path...

JohnMdz gravatar image JohnMdz  ( 2018-07-02 08:30:04 -0500 )edit

@JohnMdz i tried what you said, it looks like I am also facing the same issue. I am also getting the same warning about control loop missing its desired refresh rate. I would like to know if @pietrocolombo has figured this out or not ...

aarontan gravatar image aarontan  ( 2018-07-02 17:46:52 -0500 )edit

@JohnMdz we have not solved the issue. on the other hand we are developing another local planner

pietrocolombo gravatar image pietrocolombo  ( 2018-07-06 15:13:05 -0500 )edit

@JohnMdz did you ever find a way to handle the backwards movement issue?

jorgyz gravatar image jorgyz  ( 2019-04-04 17:07:36 -0500 )edit

unfortunately not

pietrocolombo gravatar image pietrocolombo  ( 2019-04-05 00:27:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-06 06:39:18 -0500

pavel92 gravatar image

As I can understand you want your robot to avoid in-place rotations and moving backwards.

Avoiding both backing up and in-place rotations can get your robot stuck if there is an obstacle in front of it. In this case the recovery-behavior will take place to get the robot unstuck (NOTE that the default recovery behavior rotates in place). That is set by the recovery_behaviors and clearing_rotation_allowed parameters from move_base. This means that in order to avoid in-place rotations when stuck you will need a custom recovery behavior plugin in this case.

Please post your teb_local_planner parameters (.yaml) and move_base.launch files so we can see your current configuration.

edit flag offensive delete link more

Comments

I don't fully agree. I understand that the robot may be stuck if it unable to perform backwards or in place movements/rotations. My main issue is that the planner always consider the backwards movement and not only in obstacle avoidance situations.

JohnMdz gravatar image JohnMdz  ( 2018-07-11 08:37:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-11-08 13:05:55 -0500

Seen: 787 times

Last updated: Jul 06 '18