installation issue

asked 2017-10-15 21:12:14 -0500

rnunziata gravatar image

updated 2017-10-16 00:17:40 -0500

So I had so junk bin directory. Now when I run I get something more reasonable:

ERROR: cannot launch node of type [ptam/ptam_visualizer]: can't locate node [ptam_visualizer] in package [ptam]
ERROR: cannot launch node of type [ptam/ptam]: can't locate node [ptam] in package [ptam]

If I do a ls on the devel dir the executable's are there.

ls /home/rjn/catkin_make_ws/devel/lib/ptam/
cameracalibrator  ptam  ptam_visualizer  remote_ptam

the line is present in my .bashrc file

 source /home/rjn/catkin_make_ws/devel/setup.bash

If I source it directly when I bring up the terminal window I get a different error. The node just dies.

[ptam-4] process has died [pid 28915, exit code -11, cmd /home/rjn/catkin_make_ws/devel/lib/ptam/ptam image:=/camera/image_mono pose:=pose __name:=ptam __log:=/home/rjn/.ros/log/df8e5472-b21b-11e7-8b1e-0028f87b9f9e/ptam-4.log].
log file: /home/rjn/.ros/log/df8e5472-b21b-11e7-8b1e-0028f87b9f9e/ptam-4*.log

I have four workspaces and I am wondering if this is an issue:

   source /opt/ros/kinetic/setup.bash 
   source /home/rjn/catkin_make_ws/devel/setup.bash     
   source /home/rjn/catkin_rosmake_ws/setup.bash       
   source /home/rjn/catkin_ws/devel/setup.bash

sorry only ptam being the issue now. As described above.

if I run rosrun it appears to be looking in the wrong place. Not devel/lib/ptam

rosrun ptam ptam
[rosrun] Couldn't find executable named ptam below /home/rjn/catkin_make_ws/src/ethzasl_ptam/ptam
[rosrun] Found the following, but they're either not files,
[rosrun] or not executable:
[rosrun]   /home/rjn/catkin_make_ws/src/ethzasl_ptam/ptam
[rosrun]   /home/rjn/catkin_make_ws/src/ethzasl_ptam/ptam/include/ptam
[rosrun]   /home/rjn/catkin_make_ws/src/ethzasl_ptam/ptam/src/ptam

catkin_find ptam ptam but only if I source setup.bash in the terminal. A

/home/rjn/catkin_make_ws/devel/lib/ptam/ptam
edit retag flag offensive close merge delete

Comments

I think it would help if you can clearly describe what it is you are trying to do. I have the impression that this has something to with workspace overlaying, but it's rather convoluted at the moment.

gvdhoorn gravatar imagegvdhoorn ( 2017-10-16 05:02:26 -0500 )edit

Indeed there is some kind of overlay happening , the approach I took was to convert the ethzasl_ptam to build with catkin build.

rnunziata gravatar imagernunziata ( 2017-10-16 14:17:42 -0500 )edit

@rnunziata Please don't provide answers that are not answers. Either edit your original question or post a comment. I've moved your previous answer to be a comment.

jarvisschultz gravatar imagejarvisschultz ( 2017-10-16 14:35:15 -0500 )edit