Integration of IMU with rosserial

asked 2017-08-28 14:09:48 -0500

1991dhanraj@gmail.com gravatar image

updated 2017-08-28 16:20:32 -0500

jayess gravatar image

Hi

I am using rosserial_python in order to run a ROS node on arduino.I was able to publish the odometry information from the arduino.Now i am trying to integrate IMU and i am using Adafruit 9-DOF Absolute orientation IMU Fusion Breatout-BNO055 ( https://learn.adafruit.com/adafruit-b... ).

I am able to read the data using th libaray ( https://github.com/adafruit/Adafruit_... ) but when i try to integrate rosserial with the IMU and publish the IMU data as a rosnode i get the following issue

@AGR:~$ rosrun rosserial_python serial_node.py _port:=/dev/ttyACM1 _baud:=9600
[INFO] [1503942062.205843]: ROS Serial Python Node
[INFO] [1503942062.211847]: Connecting to /dev/ttyACM1 at 9600 baud
[ERROR] [1503942077.316807]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I am not sure what is the rootcause of this problem.any inputs on this issue is appreciated.

edit retag flag offensive close merge delete

Comments

Welcome. I edited your question to make it more readable. In the future, please use the 101010 button to make your code/terminal output formatted and easier to read.

jayess gravatar image jayess  ( 2017-08-28 16:21:29 -0500 )edit

There are also many questions regarding this very same problem. Try those solutions first by Googling the error Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

jayess gravatar image jayess  ( 2017-08-28 16:22:50 -0500 )edit

I think you should select the baud rate as 115200. Check if that works.

AlexR gravatar image AlexR  ( 2017-08-29 00:49:27 -0500 )edit

Hi Alex

I did try with different baud rates but i still get the same error

1991dhanraj@gmail.com gravatar image 1991dhanraj@gmail.com  ( 2017-08-29 07:04:03 -0500 )edit