Ask Your Question
2

My workspace cannot build because assimp library update

asked 2017-08-24 04:11:12 -0600

Solrac3589 gravatar image

updated 2017-08-25 05:03:16 -0600

Hello everybody, i have a problem and I do not have any clue how to solve it.

Yesterday I updated my ubuntu 14.04 and with it, assimp was updated from 3.0 to 3.2. Until then, when i try to build the project on which im working on, it gives me this error.

/opt/ros/indigo/lib/libgeometric_shapes.so: undefined reference to `Assimp::Importer::SetPropertyInteger(char const, int, bool)'

I have been checking inside Importer file and the function SetPropertyInteger has the corresponding inputs.

i tried to downgrade from 3.2 to 3.0 but it makes me unistall all ros (i tried, and i does nto works, because when ros is installed again, the library is updated again also).

I searched info trough internet in several places and i didn't find any real clue of how to solve the error.

If anybdoy can help me, i would really feel very grateful.

PD: Yes, i think the problem is the version 3.2, not only because everything started to not work after the update, but also because my supervisor did not the upgrade and he can build correctly.

edit retag flag offensive close merge delete

Comments

@Solrac3589: This would be better and more beneficial if the answer and question were separated.

jayess gravatar imagejayess ( 2017-08-24 18:38:05 -0600 )edit

Okey, i will fix it

Solrac3589 gravatar imageSolrac3589 ( 2017-08-25 05:03:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-08-24 07:36:00 -0600

Solrac3589 gravatar image

updated 2017-08-25 05:03:33 -0600

I solved myself the problem. I just let here how i did it just in case anybody needs it.

1-Install synaptic and do all the steps with it.

2-Force assimp3 to the 3.0 version (pyton-pyassimp ,assimp-dev and all ros was uninstalled).

3-Fix the broken package assimp3 (i do not know why, the package was marked as broken always).

4-bloc the version of assimp3.

5- install the two other assimp packages in version 3.0 also (fixing them to not be broken packages and blocking also the version). One by one.

6-install ros.

7-Profit

if anybody has the problem and need extra help, send me a message trough mail (i don't know if i will enter here frequently).

edit flag offensive delete link more

Comments

Hello I am facing similar problem.I have check the details and realized ROS uses a library called assimp. In my case it might gave me error because I installed cuda and Nvidia graphic card./opt/ros/indigo/lib/libgeometric_shapes.so: undefined reference to `Assimp::Importer::SetPropertyInteger.

yashu gravatar imageyashu ( 2017-09-08 03:04:06 -0600 )edit

can you please explain me in details how you solve this problem. specifically I want to know how you bloc the version of assimp3. Thank you in advance.

yashu gravatar imageyashu ( 2017-09-08 03:08:08 -0600 )edit

in synaptic there is an option.

If you go to package menu at the top, you will see the option block version.

If you face more problems or you do not understand something, send me a mail and I will take time to solve the error with you this weekend (i am a little free).

Solrac3589 gravatar imageSolrac3589 ( 2017-09-08 05:45:30 -0600 )edit

Thank you very much for your reply. Now I will try above solution to solve my problem. I will contact you if I need any help. Thanks.

yashu gravatar imageyashu ( 2017-09-08 23:38:09 -0600 )edit

Thank you very much now its working fine.

yashu gravatar imageyashu ( 2017-09-11 00:23:34 -0600 )edit

Thanks for the help. I had the same issue and this solution solved it!!

Mario Garzon gravatar imageMario Garzon ( 2017-09-29 12:02:50 -0600 )edit

worked for me also, to fix the broken package status I needed to disable all PPA repositories in the software center

ghanimmukhtar gravatar imageghanimmukhtar ( 2017-10-12 05:51:04 -0600 )edit

To fix broken assimp packages if you have Cuda and Nvidia graphic card (means if you are using GPU in your research) then carefully select modification method. Disable all PPA repositories in the software center might be responsible for Nvidia graphic card related error.

yashu gravatar imageyashu ( 2017-10-12 07:16:37 -0600 )edit
1

answered 2017-11-29 19:30:40 -0600

rmck gravatar image

I had the same issue on Indigo. I was able to resolve it without uninstalling ROS by using dpkg to remove the problem packages without removing their dependencies.

dpkg -r --force-depends package_name

So I ran the following:

dpkg -r --force-depends python-pyassimp assimp-*

This removed the problem packages, I then removed Cuda and ran apt-get -f install which reinstalled assimp with the correct version for indigo. I've been using it successfully since then without errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-08-24 04:10:23 -0600

Seen: 844 times

Last updated: Nov 29 '17