pointcloud published at very slow rate from laser_assembler

asked 2017-07-28 03:42:26 -0600

dinesh gravatar image

updated 2017-07-28 04:04:36 -0600

My laser_scan_assembler.launch file is:

<launch>
 <node pkg="laser_assembler" type="laser_scan_assembler" output="screen"  name="laser_scan_assembler">
 <remap from="scan" to="/multisense/lidar_scan"/>
   <param name="max_scans" type="int" value="400" />
    <param name="fixed_frame" type="string" value="head" />
  </node>

 <node pkg="laser_assembler" type="periodic_snapshotter" output="screen" name="periodic_snapshotter" />

<node pkg="tf" type="static_transform_publisher" name="baselink_laser_broadcaster" args="0 0 1 0 0 0 map odom_combined 10"/>

</launch>

After i launch this file i'm getting this message:

[ INFO] [1501231708.149345614]: TF Cache Time: 10.000000 Seconds
[ INFO] [1501231708.153398871]: Max Scans in History: 400
[ INFO] [1501231708.155791735]: Fixed Frame: head
[ INFO] [1501231708.462372713, 215.177000000]: waitForService: Service [/build_cloud] is now available.
[ INFO] [1501231708.462553053, 215.177000000]: Found build_cloud! Starting the snapshotter
[ INFO] [1501231740.307119973, 225.216000000]: Published Cloud with 101810 points

When i run command rostopic hz /assembled_cloud in another terminal i get this:

subscribed to [/assembled_cloud]
WARNING: may be using simulated time
average rate: 0.200
    min: 5.008s max: 5.008s std dev: 0.00000s window: 2
no new messages
no new messages
no new messages

When i try to visualize it in rviz, i'm not getting any visual signs of pointcloud. So what should i do to make it work like normal. my urdf of the ray_sensor of multisense camera is:

  <gazebo reference="head_hokuyo_frame">
    <sensor name="head_hokuyo_sensor" type="ray">
      <pose>0 0 0 0 0 0</pose>
      <visualize>true</visualize>
      <update_rate>40</update_rate>
      <ray>
        <scan>
          <horizontal>
            <samples>1081</samples>
            <resolution>1</resolution>
            <min_angle>-2.356194</min_angle>
            <max_angle>2.356194</max_angle>
          </horizontal>
        </scan>
        <range>
          <min>0.10</min>
          <max>30.0</max>
          <resolution>0.01</resolution>
        </range>
        <noise>
          <type>gaussian</type>
          <!-- Noise parameters based on published spec for Hokuyo laser
               achieving "+-30mm" accuracy at range < 10m.  A mean of 0.0m and
               stddev of 0.01m will put 99.7% of samples within 0.03m of the true
               reading. -->
          <mean>0.0</mean>
          <stddev>0.01</stddev>
        </noise>
      </ray>
      <plugin filename="libgazebo_ros_laser.so" name="gazebo_ros_head_hokuyo_controller">
        <topicName>/multisense/lidar_scan</topicName>
        <frameName>head</frameName>
      </plugin>
    </sensor>
  </gazebo>

I am usign ros indiog, ubuntu 14.04 with xenomai patched, i build the laser_assembler package from source. Since i dind't foud the indigo version of the package i used hydro version.

edit retag flag offensive close merge delete