ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS Indigo installation problem on Raspbian Jessie

asked 2017-07-18 04:41:24 -0500

jchoi0415 gravatar image

updated 2017-07-18 08:05:23 -0500

Hi all,

I was using the tutorial [ ] to install ROS on my Raspberry Pi 3 Model B (Raspbian Jessie) to control a robot called Baxter and run Gazebo (Simulation tool for ROS).

Currently, I am having problems in the step where I have to build the catkin packages (Step 3.3 'Building the catkin Workspace' on the tutorial. The problem is that it says:

CMake Error at gtest/cmake_install.cmake:42(file):
    file INSTALL cannot find
Call Stack (most recent call first):
    cmake_install.cmake:154 (include)

Can anyone give me some directions to overcome this problem?


edit retag flag offensive close merge delete



Please don't use screenshots for what is essentially text. Just copy-paste terminal text into your question and make sure to use the Preformatted Text button (the one with 101010 on it) to format it properly.

gvdhoorn gravatar image gvdhoorn  ( 2017-07-18 05:20:50 -0500 )edit

Sorry there, first time using public Q&A forums. Fixed up my question :)

jchoi0415 gravatar image jchoi0415  ( 2017-07-18 08:07:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-08-20 10:49:08 -0500

Hobbert Evergreen gravatar image

I got the same issue ... before this error, on warnings the compiler said something about "Target "gtest" has EXCLUDE_FROM_ALL" and I thought that someone is telling to exclude and the error said this lib may be included!!

So for a rapid test I got into the

cd ~/ros_catkin_ws/src/catkin/cmake/test

and edited the gtest.cmake

sudo nano gtest.cmake

Commenting this line (#) to avoid the exclusion of this files:

    #set_target_properties(${target} PROPERTIES EXCLUDE_FROM_ALL TRUE)

and comment too

#set_target_properties(gtest gtest_main PROPERTIES EXCLUDE_FROM_ALL 1)

Save the file and try again

After that, the compiler compile the gtest and worked fine

Its not a definitive solution, but works well, it helps!!

Another aproach is to remove the gtest compile, but not tested it yet


(PS: in this tutorial they remove the ros_lisp (--exclude roslisp) because the "dependency sbcl is not available in the Raspbian" ... but I have included and the dependency is ok by now!!)

edit flag offensive delete link more


Thank you so much for those tips, it works fine with Raspbian Stretch too, following this tutorial : , in part 3.3

Near32 gravatar image Near32  ( 2017-09-25 23:18:03 -0500 )edit

Worked for me.. thank you. Working with _Jessi lite following this

JesperMarkling gravatar image JesperMarkling  ( 2018-04-26 10:03:38 -0500 )edit

Worked for me as well. Working on Stretch on Raspberry Pi 3. Thank you.

ameykasar gravatar image ameykasar  ( 2018-09-21 08:19:58 -0500 )edit

Question Tools

1 follower


Asked: 2017-07-18 04:41:24 -0500

Seen: 1,503 times

Last updated: Aug 20 '17