Ask Your Question
0

REQUIRED process [rgbdslam-2] has died!

asked 2017-06-07 04:17:33 -0600

Amir gravatar image

Hi,

I have a problem with installing rgbd-slam v2 in indigo and also kinetic, I am receiving almost a similar error in both of them. The following is for ROS Indigo/Ubuntu 14/Openni2/OpenCV2.4.11

I tried to activate and deactivate siftgpu and also tried to follow the solution mentioned in http://answers.ros.org/question/22940...

But none of them helped

Command> roslaunch rgbdslam rgbdslam.launch ... logging to /home/amir-ai/.ros/log/650d55e4-4b60-11e7-97f0-38d547df45ba/roslaunch-Amir-9405.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://Amir:39582/

SUMMARY

PARAMETERS * /rgbdslam/config/backend_solver: pcg * /rgbdslam/config/cloud_creation_skip_step: 2 * /rgbdslam/config/cloud_display_type: POINTS * /rgbdslam/config/detector_grid_resolution: 3 * /rgbdslam/config/feature_detector_type: ORB * /rgbdslam/config/feature_extractor_type: ORB * /rgbdslam/config/max_keypoints: 600 * /rgbdslam/config/max_matches: 300 * /rgbdslam/config/min_sampled_candidates: 4 * /rgbdslam/config/neighbor_candidates: 4 * /rgbdslam/config/optimizer_skip_step: 1 * /rgbdslam/config/pose_relative_to: largest_loop * /rgbdslam/config/predecessor_candidates: 4 * /rgbdslam/config/ransac_iterations: 100 * /rgbdslam/config/topic_image_depth: /camera/depth_reg... * /rgbdslam/config/topic_image_mono: /camera/rgb/image... * /rgbdslam/config/topic_points: * /rosdistro: indigo * /rosversion: 1.11.20

NODES / rgbdslam (rgbdslam/rgbdslam)

auto-starting new master process[master]: started with pid [9417] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 650d55e4-4b60-11e7-97f0-38d547df45ba process[rosout-1]: started with pid [9430] started core service [/rosout] process[rgbdslam-2]: started with pid [9441] ================================================================================REQUIRED process [rgbdslam-2] has died! process has died [pid 9441, exit code -11, cmd /home/amir-ai/catkin_ws/devel/lib/rgbdslam/rgbdslam __name:=rgbdslam __log:=/home/amir-ai/.ros/log/650d55e4-4b60-11e7-97f0-38d547df45ba/rgbdslam-2.log]. log file: /home/amir-ai/.ros/log/650d55e4-4b60-11e7-97f0-38d547df45ba/rgbdslam-2*.log

Initiating shutdown!

[rgbdslam-2] killing on exit [rosout-1] killing on exit [master] killing on exit shutting down processing monitor... ... shu.

I would appreciate your help.

edit retag flag offensive close merge delete

Comments

Hi, have you been fortunate in resolving this issue? Here is the start of my err msg:

error while loading shared libraries: libsiftgpu.so: cannot open shared object file: Error 40
REQUIRED process [rgbdslam-1] has died! 
...

I use Ubuntu 16.04 and ROS Kinetic.

Dox gravatar imageDox ( 2018-04-01 19:52:01 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-12-02 12:48:09 -0600

arminkazim gravatar image

Hey there i followed the guide from https://github.com/felixendres/rgbdsl... steps 11-16 seem to fix it so you got to rebuild rgbdslam with pcl 1.8

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-07 04:17:33 -0600

Seen: 266 times

Last updated: Dec 02