Ask Your Question
0

error message "could not find package 'ros-kinetic-desktop-full'"

asked 2017-04-13 01:21:34 -0500

Zale gravatar image

Trying to install ROS both through the terminal and by clicking on the "click here" link. In both cases I get an error message "could not find package 'ros-kinetic-desktop-full'".

What do I do now?

Thanks for your help.

Zale

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-13 04:48:32 -0500

updated 2017-04-14 13:52:53 -0500

From this page:

Make sure to run

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

and

sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116

and

sudo apt-get update

before running the installation command.

EDIT:

Now that we know that you are on Ubuntu 10.04, we can help you further. Ubuntu 10.04 are officially supported by ROS electric, which you can check out here. Of course, electric is long gone, so a better solution would be to install ROS kinetic from source, but be prepared to have (lots of?) dependency issues since you are using an outdated OS. I would strongly suggest to upgrade your OS if that's possible though.

edit flag offensive delete link more

Comments

I ran these.

The first of these asked me for my password but then didn't seem to do anything but give me back my command prompt. The second and third returned information.

Same error message on install attempt. "Unable to locate package"

Thanks for the help, but still no joy

Zale gravatar image Zale  ( 2017-04-13 10:50:28 -0500 )edit

This is very weird. What is your OS? Maybe you are not on Ubuntu 16.04?

gstavrinos gravatar image gstavrinos  ( 2017-04-13 11:17:34 -0500 )edit

No, I am on Ubuntu 16.04 That's not the problem. I've checked for typos in my commands. That doesn't seem to be the problem either.

Zale gravatar image Zale  ( 2017-04-13 14:26:26 -0500 )edit

What is your OS? You should be on 16.04 to use kinetic.

gstavrinos gravatar image gstavrinos  ( 2017-04-13 14:42:13 -0500 )edit

Yes, OS 10.04 is my operating system.

Zale gravatar image Zale  ( 2017-04-14 13:31:08 -0500 )edit

Check the edited answer.

gstavrinos gravatar image gstavrinos  ( 2017-04-14 13:48:59 -0500 )edit

Damn, that was a typo. I am on ubuntu 16.04. Sorry about that. Don't know how that slipped past me.

Zale gravatar image Zale  ( 2017-04-15 02:12:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-13 01:21:34 -0500

Seen: 2,388 times

Last updated: Apr 14 '17