ROSLaunch not working [closed]

asked 2017-04-08 04:44:33 -0500

billy gravatar image

updated 2017-04-09 20:54:55 -0500

I am using ROS Jade on Ubuntu 14.04.

My ROS setup has been working fine, but I recently installed java as required for the openni installation, and installed the openni along with files needed for the kinect camera. Now I have a particular launch file that errors with message of not being able to find the nodes. Here is the output from the launch file:

... logging to /home/billy/.ros/log/17d5e0de-1c3a-11e7-8d67-100ba9588b18/roslaunch-billy-ThinkPad-T420-4123.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://billy-ThinkPad-T420:44143/

SUMMARY
========

PARAMETERS
 * /rosdistro: jade
 * /rosversion: 1.11.20
 * /xv_11_node/message_logging: 0
 * /xv_11_node/port: /dev/ttyUSB0

NODES
  /
    base_link_to_laser_and_imu (robot_setup_tf/tf_broadcaster)
    cmd_publisher (cmd_publisher/cmd_publisher)
    robot_state_machine (robot_state_machine/robot_state_machine)
    serial_port_sender (serial_port_sender/serial_port_sender)
    xv_11_node (xv_11_laser_driver/neato_laser_publisher)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
ERROR: cannot launch node of type [xv_11_laser_driver/neato_laser_publisher]: can't locate node [neato_laser_publisher] in package [xv_11_laser_driver]
ERROR: cannot launch node of type [robot_setup_tf/tf_broadcaster]: can't locate node [tf_broadcaster] in package [robot_setup_tf]
ERROR: cannot launch node of type [cmd_publisher/cmd_publisher]: can't locate node [cmd_publisher] in package [cmd_publisher]
ERROR: cannot launch node of type [serial_port_sender/serial_port_sender]: can't locate node [serial_port_sender] in package [serial_port_sender]
ERROR: cannot launch node of type [robot_state_machine/robot_state_machine]: can't locate node [robot_state_machine] in package [robot_state_machine]
No processes to monitor
shutting down processing monitor...
... shutting down processing monitor complete

I have properly sourced devel/setup.bash. I have deleted the entire build and devel folders and remade them using catkin_make.

The packages are found using rospack find

billy@billy-ThinkPad-T420:~/catkin_ws$ rospack find serial_port_sender
/home/billy/catkin_ws/src/serial_port_sender

I have verified the build folder has the files after making.

Each of the nodes called in this launch is complied from source (these are my nodes). The launch file for launching the navigation stack is the same folder as this laucnh file and it works as usual.

I have verified the ROS_PACKAGE_PATH is correct:

billy@billy-ThinkPad-T420:~/catkin_ws$ echo $ROS_PACKAGE_PATH
/home/billy/catkin_ws:/home/catkin_ws:/opt/ros/jade/share:/opt/ros/jade/stacks

The detailed message from the log file may help you understand but I wasn't able to get anything useful from it:

[roslaunch][INFO] 2017-04-08 02:06:59,005: ... preparing to launch node of type [robot_setup_tf/tf_broadcaster]
[roslaunch][INFO] 2017-04-08 02:06:59,005: create_node_process: package[robot_setup_tf] type[tf_broadcaster] machine[Machine(name[] env_loader[None] address[localhost] ssh_port[22] user[None] assignable[True] timeout[10.0])] master_uri[http://localhost:11311]
[roslaunch][INFO] 2017-04-08 02:06:59,006: process[base_link_to_laser_and_imu-2]: env[{'WINDOWID': '62918866', 'QT_QPA_PLATFORMTHEME': 'appmenu-qt5', 'ROS_DISTRO': 'jade', 'XDG_GREETER_DATA_DIR': '/var/lib/lightdm-data/billy', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'UPSTART_EVENTS': 'started starting', 'LESSOPEN': '| /usr/bin/lesspipe %s', 'XDG_SEAT_PATH': '/org/freedesktop/DisplayManager/Seat0', 'ROSLISP_PACKAGE_DIRECTORIES': '', 'CPATH': '/opt/ros/jade/include', 'LOGNAME': 'billy', 'USER': 'billy', 'PATH': '/opt/ros/jade/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/java/jre1.8.0_121/bin:/usr/local/java/jdk1.8.0_121/bin', 'XDG_VTNR ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by DavidN
close date 2017-04-12 01:10:11.400503

Comments

1

2 things to check: 1. Can you do roscd serial_port_sender and other packages? 2. cd to your_workspace/devel/lib/, do you see all of your nodes in the corresponding package folder? E.g. serial_port_sender in serial_port_sender folder, tf_broadcaster in robot_setup_tf folder...

DavidN gravatar imageDavidN ( 2017-04-09 07:55:10 -0500 )edit
1

Also, did you compile with catkin_make or catkin_make install?

DavidN gravatar imageDavidN ( 2017-04-09 08:00:47 -0500 )edit

Davidn - thanks for your help. Answers: 1 - yes, 2 - yes, 3 - after deleting build and devel folders I ran 'catkin_make' and it didn't work. Then ran 'catkin_make install' and it didn't work. Today, deleting the folders and running 'catkin_make install' did work. Now it's all good! Order important!

billy gravatar imagebilly ( 2017-04-09 15:11:38 -0500 )edit

So I spoke too soon. The launch file worked once this morning, but now back to not working, even after deleting the install, build, and devel folders and running caktin_make install. Back to square 1.

billy gravatar imagebilly ( 2017-04-09 20:00:08 -0500 )edit

Ok. so in step 2, you could see your nodes in respective packages, right? Can you use rosrun to launch your node? Try to do it one by one to make sure all the nodes are "runnable".

DavidN gravatar imageDavidN ( 2017-04-09 20:45:05 -0500 )edit

I can see them but cannot use rosrun to launch them. I will update the question with the errors I get attempting rosrun.

billy gravatar imagebilly ( 2017-04-09 20:48:43 -0500 )edit
1

You normally can't use the install and the devel space at the same time. If you have targets that are only being built when you run catkin_make install you might want to try sourcing the setup.bash script that is in the install/ directory instead of the devel/ directory

jarvisschultz gravatar imagejarvisschultz ( 2017-04-10 07:59:37 -0500 )edit

Jarvi, I've been trying with both catkin_make and catkin_make install. The response to the launch file and rosrun have been the same except for a single case yesterday where launch worked once after running catkin_make install. Any other ideas will be appreciated.

billy gravatar imagebilly ( 2017-04-10 11:27:25 -0500 )edit