Moveit Benchmarking cant plot PDF

asked 2017-03-28 04:46:26 -0500

Rhemus gravatar image

updated 2017-03-29 02:44:17 -0500

Hey guys,

i did benchmarking with moveit already some times and it always worked well. I get a perfect .log file which i converted sometimes into a pdf. After a few runs, i get the .log file but cant convert it into a pdf anymore. I used the same code all the time and only changed the planners to benchmark.

When i now run

rosrun moveit_ros_benchmarks -d benchmark.db catkin_ws/src/mrk_gazebo_hofmann/launch/result.log.1.log -p ur5_benchmarking.pdf

i get an error message:

Generating plot...
Traceback (most recent call last):
  File "/opt/ros/indigo/lib/moveit_ros_benchmarks/", line 432, in <module>
    plot_statistics(options.dbname, options.plot)
  File "/opt/ros/indigo/lib/moveit_ros_benchmarks/", line 236, in plot_statistics
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 2303, in savefig
    figure.savefig(self, format='pdf', **kwargs)
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 1421, in savefig
    self.canvas.print_figure(*args, **kwargs)
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 2220, in print_figure
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 2352, in print_pdf
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 55, in draw_wrapper
    draw(artist, renderer, *args, **kwargs)
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 1034, in draw
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 55, in draw_wrapper
    draw(artist, renderer, *args, **kwargs)
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 2086, in draw
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 55, in draw_wrapper
    draw(artist, renderer, *args, **kwargs)
  File "/usr/lib/pymodules/python2.7/matplotlib/", line 598, in draw
    ismath=ismath, mtext=self)
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 1943, in draw_text
    return draw_text_simple()
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 1875, in draw_text_simple
    self._setup_textpos(x, y, angle)
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 1644, in _setup_textpos
    self.file.output(x - oldx, y - oldy, Op.textpos)
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 548, in output
    self.write(fill(map(pdfRepr, data)))
  File "/usr/lib/pymodules/python2.7/matplotlib/backends/", line 144, in pdfRepr
    raise ValueError("Can only output finite numbers in PDF")
ValueError: Can only output finite numbers in PDF

i cant find a solution for this problem, because it already worked before. Maybe someone of you can help. Im running ROS Indigo on Ubuntu 14.04.

Edit: When i run the same planners which worked before, i get the same error. This is the .log File:

Experiment UR5
Running on Donnas
Starting at 2017-03-28T11:29:29.263611
Goal name q_ur5
5 seconds per run
14.5057 seconds spent to collect the data
2 planners
0 common properties
18 properties for each run
path_interpolate_clearance REAL
path_interpolate_correct BOOLEAN
path_interpolate_length REAL
path_interpolate_smoothness REAL ...
edit retag flag offensive close merge delete


Can only output finite numbers in PDF

that looks like an error from matplotlib, not the benchmarking code directly.

Can you check whether there are any NaNs or Infs in the results?

gvdhoorn gravatar image gvdhoorn  ( 2017-03-28 06:12:59 -0500 )edit

No there are no NaN or Inf in the results. I have added the .log file above.

Rhemus gravatar image Rhemus  ( 2017-03-28 06:31:57 -0500 )edit