ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

Mac Pro install ROS indigo failed in "qt_gui_cpp" error: code requires Qt 4.x

asked 2017-03-20 23:40:05 -0500

DinnerHowe gravatar image

updated 2017-03-21 00:37:09 -0500

hi all:

I'm trying to install ROS indigo into Mac Pro with macOS Sierra 10.12.3.

I follow this tutorial(http://wiki.ros.org/indigo/Installation/OSX/Homebrew/Source), however, it does not looks like such easy for me.

now, I have a trouble about qt4, the error is showing below:

CMake Error at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindQt4.cmake:1318 (message):
  Found unsuitable Qt version "5.8.0" from /usr/local/opt/qt5/bin/qmake, this
  code requires Qt 4.x
Call Stack (most recent call first):
  src/qt_gui_cpp/CMakeLists.txt:3 (find_package)


-- Configuring incomplete, errors occurred!
See also "/Users/howe/ROS_Howe/build_isolated/qt_gui_cpp/CMakeFiles/CMakeOutput.log".
<== Failed to process package 'qt_gui_cpp': 
  Command '['/Users/howe/ROS_Howe/install_isolated/env.sh', 'cmake', '/Users/howe/ROS_Howe/src/qt_gui_core/qt_gui_cpp', '-DCATKIN_DEVEL_PREFIX=/Users/howe/ROS_Howe/devel_isolated/qt_gui_cpp', '-DCMAKE_INSTALL_PREFIX=/Users/howe/ROS_Howe/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /Users/howe/ROS_Howe/build_isolated/qt_gui_cpp && /Users/howe/ROS_Howe/install_isolated/env.sh cmake /Users/howe/ROS_Howe/src/qt_gui_core/qt_gui_cpp -DCATKIN_DEVEL_PREFIX=/Users/howe/ROS_Howe/devel_isolated/qt_gui_cpp -DCMAKE_INSTALL_PREFIX=/Users/howe/ROS_Howe/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

I checked my qt4, and tried all solutions in rosanswers forum, None of them worked. while, the qt4 info is showing below.

cartr/qt4/qt: stable 4.8.7 (bottled), HEAD
Cross-platform application and UI framework
https://www.qt.io/
/usr/local/Cellar/qt/4.8.7_3 (2,720 files, 109.4MB) *
  Poured from bottle on 2017-03-21 at 10:28:32
From: https://github.com/cartr/homebrew-qt4/blob/master/qt.rb
==> Dependencies
Required: openssl ✔
Optional: dbus ✘, mysql ✘, postgresql ✘
==> Requirements
Build: git ✔
==> Options
--with-dbus
    Build with dbus support
--with-docs
    Build documentation
--with-mysql
    Build with mysql support
--with-postgresql
    Build with postgresql support
--with-qt3support
    Build with deprecated Qt3Support module support
--without-webkit
    Build without QtWebKit module
--HEAD
    Install HEAD version
==> Caveats
We agreed to the Qt opensource license for you.
If this is unacceptable you should uninstall.

Qt Designer no longer picks up changes to the QT_PLUGIN_PATH environment
variable as it was tweaked to search for plug-ins provided by formulae in
  /usr/local/lib/qt4/plugins

thus, could anyone help me on this problem? thank you for reading and thanks advance

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-03-22 22:46:54 -0500

DinnerHowe gravatar image

while, I figure out how to install qt4

brew tap cartr/qt4
brew tap-pin cartr/qt4
brew install qt

while now the problem is I need to install qt4-no-webkit, when I go through gazebo installation

here is the discussion: https://github.com/mikepurvis/ros-ins...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-20 23:40:05 -0500

Seen: 522 times

Last updated: Mar 22 '17