Ask Your Question
0

rqt freezes

asked 2017-03-08 03:56:25 -0500

Azhar gravatar image

I am creating a GUI for a robot using rqt_gui, both connected together by the same WIFI network.

The plugins in my rqt_gui are 1) RVIZ, 2) Image_view and 3)dynamic_reconfigure.

Whenever i run the rqt_gui, and access RVIZ , the whole rqt_gui freezes and turns black shortly. Thus i am unable to do anything with it.

RVIZ - For LIDAR map and navigation through it

Image_view - To have live camera feed from the robot

rqt_dynamic_reconfigure - to change the parameters of the robot from the laptop

Can someone please tell me why am i facing the problem and is there any solution to the problem!

My laptop is Lenovo ideapad 700 running in Ubuntu 14.04 and ROS Indigo.

Please let me know if there is need for any other info.

Any form of help would be apprciated!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-08 08:53:27 -0500

130s gravatar image

Not really an answer, but you may want to separately open rqt windows to receive high amount of data.

In your particular case, both rqt_rviz with laser output and rqt_image_view with camera images can be receiving very high amount of data and thus take up computer resource. Note that rqt_rviz wiki page states it's experimental and using the standalone RViz is recommended.

edit flag offensive delete link more

Comments

Thank you for your response! :) Will try to do it!

I wanted to create a GUI with everything on one screen. I was just thinking what could be the reason, and how to improve it.

Any idea of how to handle high amount of data so that it will flow with low latency?

Azhar gravatar image Azhar  ( 2017-03-08 23:21:03 -0500 )edit

Hi, I tried it, RVIZ standalone and it still freezes! :(

Can anyone give me a heads up of what to check? Network? laptop configuration?

Azhar gravatar image Azhar  ( 2017-03-13 05:50:09 -0500 )edit
1

it froze again when i open image_view in rqt too. However, when i open both the map and image(theora) from Rviz it works fine. :)

Do take note that i am using to view all this from a slave machine.

Currently, when i try to visualize the Laserscans in RVIZ alone, it freezes. Debugging in progess!

Azhar gravatar image Azhar  ( 2017-03-22 07:43:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-08 03:56:25 -0500

Seen: 394 times

Last updated: Mar 08 '17