Ask Your Question
0

Robot does not listen to 2d pose estimate

asked 2017-02-08 23:40:25 -0500

Acecryz gravatar image

updated 2017-02-09 02:22:56 -0500

mgruhler gravatar image

when I try to tell it's 2d pose estimate it just stays where it is and show particle clouds around it's wrong location.

that is shown in this image.

I am very new to ros and i'm running out of time where learning step by step is more or less out of my options any help would be appreciated

    yinht@yinht-desktop:~$ rosnode info /rviz_1486627152348467684 
--------------------------------------------------------------------------------
Node [/rviz_1486627152348467684]
Publications: 
 * /initialpose [geometry_msgs/PoseWithCovarianceStamped]
 * /rosout [rosgraph_msgs/Log]
 * /goal [geometry_msgs/PoseStamped]

Subscriptions: 
 * /camera/rgb/image_raw [sensor_msgs/Image]
 * /scan2 [unknown type]
 * /move_base/local_costmap/footprint [geometry_msgs/PolygonStamped]
 * /tf [tf2_msgs/TFMessage]
 * /scan [sensor_msgs/LaserScan]
 * /tf_static [tf2_msgs/TFMessage]
 * /particlecloud [geometry_msgs/PoseArray]
 * /map_updates [unknown type]
 * /map [nav_msgs/OccupancyGrid]

Services: 
 * /rviz_1486627152348467684/get_loggers
 * /rviz_1486627152348467684/reload_shaders
 * /rviz_1486627152348467684/set_logger_level


contacting node http://yinht-desktop:41402/ ...
Pid: 27477
Connections:
 * topic: /rosout
    * to: /rosout
    * direction: outbound
    * transport: TCPROS
 * topic: /tf
    * to: /diffusion_tf (http://yinht-desktop:38259/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /camera_base_link2 (http://yinht-desktop:46817/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /amcl (http://yinht-desktop:42593/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /camera_base_link (http://yinht-desktop:37021/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /camera_base_link3 (http://yinht-desktop:43573/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /camera_base_link1 (http://yinht-desktop:35271/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf
    * to: /robot_state_publisher (http://yinht-desktop:38135/)
    * direction: inbound
    * transport: TCPROS
 * topic: /tf_static
    * to: /robot_state_publisher (http://yinht-desktop:38135/)
    * direction: inbound
    * transport: TCPROS
 * topic: /particlecloud
    * to: /amcl (http://yinht-desktop:42593/)
    * direction: inbound
    * transport: TCPROS
 * topic: /camera/rgb/image_raw
    * to: /camera/camera_nodelet_manager (http://yinht-desktop:41082/)
    * direction: inbound
    * transport: TCPROS
 * topic: /move_base/local_costmap/footprint
    * to: /move_base (http://yinht-desktop:34315/)
    * direction: inbound
    * transport: TCPROS
 * topic: /map
    * to: /map_server (http://yinht-desktop:41602/)
    * direction: inbound
    * transport: TCPROS
 * topic: /scan
    * to: /hokuyo_laser (http://yinht-desktop:44867/)
    * direction: inbound
    * transport: TCPROS

image descriptionimage description

edit retag flag offensive close merge delete

Comments

a bit more information would be appreciated. E.g. what localization are you using? I am guessing amcl?

The amcl inipose topic is initialpose. So check that your are actually sending this there.

Also, is rviz on a remote machine? This could make a difference too

mgruhler gravatar imagemgruhler ( 2017-02-09 01:34:44 -0500 )edit

yes I am using amcl, initialpose has a connection to the /amcl. I am not using a remote machine it's on the same PC. I will post my rqt_graph if that helps

Acecryz gravatar imageAcecryz ( 2017-02-09 01:46:56 -0500 )edit

with rviz running, please...

mgruhler gravatar imagemgruhler ( 2017-02-09 01:49:26 -0500 )edit

rviz is running

Acecryz gravatar imageAcecryz ( 2017-02-09 01:55:50 -0500 )edit

but not showing up in the graph. Please configure the graph so that we see it. Or: rosnode info /rviz_5468461351 (check to get the right one, should have some numbers trailing).

mgruhler gravatar imagemgruhler ( 2017-02-09 02:02:13 -0500 )edit

Node [/rviz_5467461351] Publications: None

Subscriptions: None

Services: None

cannot contact [/rviz_5467461351]: unknown node

Acecryz gravatar imageAcecryz ( 2017-02-09 02:06:36 -0500 )edit

Alright: rosnode info /rviz_ then hit tab and take the one that actually completes!

mgruhler gravatar imagemgruhler ( 2017-02-09 02:12:31 -0500 )edit

I updated the question with the rosnode info /rviz_ sorry I tried using the preformatted text button but it didn't work

Acecryz gravatar imageAcecryz ( 2017-02-09 02:21:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-09 01:43:33 -0500

mgruhler gravatar image

See answer in your other question

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-08 23:40:25 -0500

Seen: 525 times

Last updated: Feb 09 '17