Ask Your Question
0

stl files are too big in rviz

asked 2017-02-05 13:51:08 -0500

yams gravatar image

im putting my stl filesin my urdf file but when i see it in rviz ,its too large.can someone help me with it

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-05 13:58:38 -0500

gvdhoorn gravatar image

ROS uses SI units for everything, so also in URDF (for link lengths) and for meshes. See REP-003, section Units.

You'll have to make sure your meshes use metres as scale. Meshes exported by CAD tools often use millimetres, so they will be a 1000 times too large.


If you don't want to or can't scale your meshes, you could use the scale attribute on the mesh element in your urdf. See wiki/urdf/XML/link - Elements for more information.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-02-05 13:51:08 -0500

Seen: 440 times

Last updated: Feb 05 '17