Wstool doing nothing

asked 2017-01-30 10:01:50 -0600

Yonahel gravatar image

updated 2017-02-09 02:39:59 -0600

gvdhoorn gravatar image

I was following the instructions for installing ROS Indigo on a Raspberry Pi.

I was following the instructions for Jessie, and as soon as I tried to run rosdep init and rosdep update, the command executed immediately and nothing occured. Rosinstall_generator did generate the .rosinstall file, but when I went to wstool it, nothing happened and the src folder was not created. Can anyone provide me assistance with this issue?


Edit: I literally am going to copy paste the lines from the tutorial, because that's what I ran :

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu jessie main" > /etc/apt/sources.list.d/ros-latest.list'
wget https://raw.githubusercontent.com/ros/rosdistro/master/ros.key -O - | sudo apt-key add -

sudo apt-get update
sudo apt-get upgrade

sudo apt-get install python-pip python-setuptools python-yaml python-distribute python-docutils python-dateutil python-six
sudo pip install rosdep rosinstall_generator wstool rosinstall

sudo rosdep init               //Stopped working here
rosdep update

mkdir ~/ros_catkin_ws
cd ~/ros_catkin_ws

rosinstall_generator desktop --rosdistro indigo --deps --wet-only --exclude roslisp --tar > indigo-desktop-wet.rosinstall                      //Worked
wstool init src indigo-desktop-wet.rosinstall             //Didnt work, no src made

Edit: When I ran the requested Python one-liner, the following was the result:

Content-Security-Policy: default-src 'none'; style-src 'unsafe-inline'
Strict-Transport-Security: max-age=31536000
X-Content-Type-Options: nosniff
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
ETag: "cd896919c0484ddcab1a6577e26400ec4bda95ad"
Content-Type: text/plain; charset=utf-8
Cache-Control: max-age=300
X-Geo-Block-List:
X-GitHub-Request-Id: 3F5E:623E:871232:8B11CC:589BACF0
Content-Length: 1901
Accept-Ranges: bytes
Date: Wed, 08 Feb 2017 23:46:52 GMT
Via: 1.1 varnish
Connection: close
X-Served-By: cache-jfk8147-JFK
X-Cache: HIT
X-Cache-Hits: 1
X-Timer: S1486597612.745848,VS0,VE0
Vary: Authorization,Accept-Encoding
Access-Control-Allow-Origin: *
X-Fastly-Request-ID: 574bb9d87abdf00497b66c3bd0f58391bf6ff0b3
Expires: Wed, 08 Feb 2017 23:51:52 GMT
Source-Age: 252
edit retag flag offensive close merge delete

Comments

What does "when I went to wstool it" mean exactly?

gvdhoorn gravatar image gvdhoorn  ( 2017-01-30 11:13:22 -0600 )edit

Running the command wstool init src indigo-desktop-wet.rosinstall

Yonahel gravatar image Yonahel  ( 2017-01-30 15:20:03 -0600 )edit
1

I've just followed the steps the tutorial lists: the src directory was created by wstool and it started downloading all the tarballs.

Can you please add the exact steps you used that lead to the unexpected behaviour to your question? Please use the edit button/link for that.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 02:14:22 -0600 )edit

I followed the exact instructions to the tutorial and nothing more.

Yonahel gravatar image Yonahel  ( 2017-01-31 12:29:35 -0600 )edit

If you could please copy/paste the exact lines that you are executing in your terminal into your question text, we can help you diagnose what is going on. I can't reproduce your problem, so it's going to be difficult otherwise.

Also: copy/paste, don't type. It's easy to make mistakes.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 12:46:25 -0600 )edit

Well, then I'm sorry, but I can't help you, as I can't reproduce this.

Perhaps another board member recognises your issue and can help you further.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 13:16:19 -0600 )edit
sudo rosdep init  // Stopped working here

What 'stopped working here', exactly?

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 13:18:52 -0600 )edit

It didn't take the usual amount of time to run (I've installed ROS about 8 different times on multiple machines, and this was the first time rosdep init and rosdep update did nothing when I pressed enter, just let me enter a new command).

Yonahel gravatar image Yonahel  ( 2017-01-31 13:47:58 -0600 )edit