Ask Your Question
1

image_transport rosbag issue

asked 2017-01-06 10:04:08 -0600

roboticom314 gravatar image

updated 2017-01-06 12:54:04 -0600

Has anyone else seen problems recording rosbags for all topics of a node using image_transport?

ERROR [/tmp/buildd/ros-indigo-compressed-depth-image-transport-1.9.2-0trusty-20150729-0539/src/compressed_depth_publisher.cpp:223(CompressedDepthPublisher::publish)

...

Compressed Depth Image Transport -Compression requires single-channel 32bit-floating point or 16bit raw depth images (input format is: bgr8).

I see this with pointgrey_camera_driver (tag 0.12.1) when doing a rosbag record -a. I've noticed some issues posted for other packages using image_transport so I thought I'd post a general question in the event there is some broader issue.

UPDATE: Running rosbag record -a -x "(.*)/compressed(.*)" solves the issue of the errors by not recording the "compressed" topics but doesn't explain why they occur in the first place.

edit retag flag offensive close merge delete

Comments

Hi, I'm also facing the same issue.

robot_commander gravatar imagerobot_commander ( 2018-01-29 14:10:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-09-07 03:34:29 -0600

moooeeeep gravatar image

updated 2018-09-07 03:41:08 -0600

It seems that the normal image is processed by an image_transport plugin that normally expects depth images only, after the topic *compressedDepth* is first subscribed, e.g. by rosbag record -a.

I solved the issue for me by disabling the plugin as described in the answer to this question: https://answers.ros.org/question/255970 (and here: https://github.com/ros-drivers/usb_ca... ). The topics that produce the errors then disappear, and I can safely record everything without triggering these errors.

The launch file I've ended up using roughly goes like this:

<launch>
    <group ns="camera/front">
        <!-- launch camera -->
        <node pkg="libuvc_camera" type="camera_node" name="camera_node">
            <!-- parameters here -->
        </node>

        <!-- disable compressed depth plugin for image transport -->
        <group ns="image_raw">
            <rosparam param="disable_pub_plugins">
              - 'image_transport/compressedDepth'
            </rosparam>
        </group>
    </group>
</launch>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-01-06 10:04:08 -0600

Seen: 1,643 times

Last updated: Sep 07 '18