When using rostopic list only two topics are shown

asked 2016-12-19 08:11:09 -0600

Ausgang gravatar image

I'm just starting to use ROS, so this must be really simple, but when I use rostopic list I get the following output:

turtlebot@m01:~$ rostopic list

/rosout

/rosoutagg

When my expected output is:

/odom

/mobile_base/commands/velocity

/mobile_base/commands/sound

/mobile_base/commands/reset_odometry

/mobile_base/sensors/bumper_pointcloud

/mobile_base/events/cliff

/camera/rgb/image_color/compressed

/scan

What can be causing this?

edit retag flag offensive close merge delete

Comments

It seems like you are only running roscore and no other nodes...

jsanch2s gravatar image jsanch2s  ( 2016-12-19 08:42:17 -0600 )edit

You started the nodes with another roscore?

NEngelhard gravatar image NEngelhard  ( 2016-12-19 09:23:34 -0600 )edit

whats the output of rosnode list?

shoemakerlevy9 gravatar image shoemakerlevy9  ( 2016-12-19 09:56:23 -0600 )edit

I ran roscore and then got the output listed above when using rostopic list. If the case is that I'm not running other nodes, how do I run them? In addition, I'm without access to the setup now, so I'll only be able to run rosnode list later or tomorrow.

Ausgang gravatar image Ausgang  ( 2016-12-19 10:15:33 -0600 )edit

After starting roscore use$ rosrun [package_name] [node_name] to start nodes. Once your comfortable starting nodes that way you will want to switch to using launch files and $ rosrun [package_name] [launch_file]

shoemakerlevy9 gravatar image shoemakerlevy9  ( 2016-12-19 10:35:31 -0600 )edit

Isn't there a way to start ROS with those nodes already? From what I can gather, the nodes I want are the most basic, things like speed control and such.

Ausgang gravatar image Ausgang  ( 2016-12-19 12:03:46 -0600 )edit

For that you might want to look into roslaunch. A simple example for reference would be this.

hamzamerzic gravatar image hamzamerzic  ( 2016-12-19 20:53:27 -0600 )edit