Ask Your Question
0

run the roslaunch comman in Qt creator

asked 2016-11-21 21:20:57 -0500

Nicky0201 gravatar image

updated 2016-11-22 02:04:00 -0500

gvdhoorn gravatar image

I tried to run the roslaunch command in Qt but the error is:

sh: 1: /opt/ros/indigo/bin/roslaunch/roslaunch: not found

and I tried to download the plugin for ROS it still doesn't work.

and here is my code:

QProcess * exec;
exec =new QProcess(this);
exec->setProcessChannelMode(QProcess::MergedChannels);
//exec->start("gnome-terminal", QStringList()<<"source ~/catkin_ws/devel/settup.bash; roslaunch p2os_launch pioneer_joy_drive.launchS ")
QString command = "/opt/ros/indigo/bin/roslaunch/roslaunch p2os_launch pioneer_joy_drive.launch";
exec->start(command);
system(qPrintable(command));
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-09-28 17:43:30 -0500

FábioBarbosa gravatar image

Have you tried writing only "roslaunch" instead of "/opt/.../roslaunch"?

Dont known if it helps, but heres one solution for a similiar situation: link text

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-21 21:20:57 -0500

Seen: 1,021 times

Last updated: Sep 28 '17