ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosserial arduino connectivity problem " socket.error: [Errno 111] Connection refused"

asked 2016-11-17 01:39:50 -0500

Wael gravatar image

I am using Ubuntu 14.04LTS with Indigo ROS and an Arduino Mega 2560. When I run the command rosrun rosserial_python _port:=/dev/ttyACM0 _baud:=115200, I faced some connection problems first this command was working normally and the serial connection was connected successfully with the Arduino. suddenly after restart my PC the following Error was appear "socket.error: [Errno 111] Connection refused" and serial connection didn't established.

The following codes i write it by sequence :

> sudo usermod -a -G dialout wael
> sudo chmod a+rw /dev/ttyACM0
> rosrun rosserial_python _port:=/dev/ttyACM0 _baud:=115200

The following error appear

Traceback (most recent call last):
  File "/opt/ros/indigo/lib/rosserial_python/", line 46, in <module>
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rospy/", line 323, in init_node
    _init_node_params(argv, name)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rospy/", line 186, in _init_node_params
    set_param(rosgraph.names.PRIV_NAME + param_name, param_value)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rospy/", line 504, in set_param
    _param_server[param_name] = param_value #MasterProxy does all the magic for us
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rospy/", line 148, in __setitem__, rospy.names.resolve_name(key), val)
  File "/usr/lib/python2.7/", line 1233, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/", line 1587, in __request
  File "/usr/lib/python2.7/", line 1273, in request
    return self.single_request(host, handler, request_body, verbose)
  File "/usr/lib/python2.7/", line 1301, in single_request
    self.send_content(h, request_body)
  File "/usr/lib/python2.7/", line 1448, in send_content
  File "/usr/lib/python2.7/", line 975, in endheaders
  File "/usr/lib/python2.7/", line 835, in _send_output
  File "/usr/lib/python2.7/", line 797, in send
  File "/usr/lib/python2.7/", line 778, in connect
    self.timeout, self.source_address)
  File "/usr/lib/python2.7/", line 571, in create_connection
    raise err
socket.error: [Errno 111] Connection refused

What can i do please to solve this problem?

edit retag flag offensive close merge delete



Have you set ROS_MASTER_URI or ROS_IP or ROS_HOSTNAME to something yourself? Are you on a DHCP network and could your IP have changed?

gvdhoorn gravatar image gvdhoorn  ( 2016-11-17 02:08:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-11-17 05:10:49 -0500

Wael gravatar image

The problem was in the ROS_MASTER_URI , it was not activated. After activating it the problem solved. Thank you for your support.

edit flag offensive delete link more


Thanks for your comment, it helps.

shawnysh gravatar image shawnysh  ( 2017-01-12 02:31:22 -0500 )edit

How to activate it?

himS1234 gravatar image himS1234  ( 2018-06-12 03:51:48 -0500 )edit

Just type 'roscore'

Carls gravatar image Carls  ( 2020-04-28 13:14:41 -0500 )edit

Question Tools


Asked: 2016-11-17 01:39:50 -0500

Seen: 4,257 times

Last updated: Nov 17 '16