ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

Installing turtlebot on ROS kinetic

asked 2016-10-19 13:42:53 -0500

homagni gravatar image

I am using a master computer to control my turtlebot. My master computer has ubuntu 16.04 xenial, so I was wondering whether turtlebot will work with it and if it does, how to install turtlebot for xenial. In most of the tutorials it says turtlebot is supported for only ROS indigo, so what do I do?

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
2

answered 2016-10-19 15:40:42 -0500

tfoote gravatar image

The TurtleBot packages have been released for Kinetic.

See the tutorials here: http://wiki.ros.org/Robots/TurtleBot

edit flag offensive delete link more

Comments

the tutorials all point to ros indigo..do I just blindly follow them for ROS kinetic too? Wont there be any changes for installing turtlebot for ROS kinetic? Can you please paste the link to the instructions? Thanking you

homagni gravatar imagehomagni ( 2016-10-19 20:00:30 -0500 )edit

Generally everything that worked in indigo is expected to work in kinetic. Just replace the keywords and use Xenial instead of Trusty.

tfoote gravatar imagetfoote ( 2016-10-19 20:19:36 -0500 )edit

Do I need to replace keyword indigo with keywords like kinetic anywhere?

homagni gravatar imagehomagni ( 2016-10-19 20:42:27 -0500 )edit
1

Hello~ all I also have the same problems to install Turtlebot packages on ROS-kinetic. I followed instruction to install turtlebot deb by replacing indigo to kinetic. but still some errors there...

Any obvious solution for this ? thank you!

Eric_ROS gravatar imageEric_ROS ( 2016-11-21 21:51:13 -0500 )edit

Replacing indigo with kinetic in the current tutorial install line fails due to ros-kinetic-rocon-remocon and ros-kinetic-rocon-qt-library not being found. Removing them works though might impact some functionality.

jwhendy gravatar imagejwhendy ( 2017-05-08 16:30:54 -0500 )edit

How did you get on with this? I have the same issue and I am worried I will run into problems down the line.

srf gravatar imagesrf ( 2017-10-13 04:52:20 -0500 )edit

@srf I don't know! I might have abandoned as I don't recall doing much with the turtlebot. That said, the other day followed along with a tutorial and launched a turtlebot in a gazebo and it worked, so maybe it updated itself away?

jwhendy gravatar imagejwhendy ( 2017-11-08 21:44:49 -0500 )edit
2

answered 2017-05-13 15:25:46 -0500

stillgreyfox gravatar image

Hi all!

This thread also exists here: http://answers.ros.org/question/249348/installing-turtlebot-for-kinetic/

I submitted my solution to it, but thought it might be appreciated here too, so here's a convenience copy:


I was really having trouble getting this to work, FINALLY found out how to get turtlebot to install cleanly on kinetic!

#TLDR;

Do this:

sudo apt-get install -y linux-headers-generic
sudo sh -c 'echo "deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted" > \
  /etc/apt/sources.list.d/official-source-repositories.list'
sudo apt-get update
sudo apt-get install -y ros-kinetic-librealsense
sudo apt-get install -y ros-kinetic-librealsense-camera
sudo apt-get install -y ros-kinetic-turtlebot

Or see my full ROS setup script


Here's my route to the solution:

First hint came from doing a wildcard turtlebot install attempt

sudo apt-get install ros-kinetic-turtlebot*

This gave me a gem in that it told me why it couldn't install the -bringup package:

The following packages have unmet dependencies:
 ros-kinetic-turtlebot-bringup : Depends: ros-kinetic-realsense-camera but it is not going to be installed

Dern you RealSense!

Going further down the rabbit hole, I tried

sudo apt-get install ros-kinetic-realsense-camera

Got this

The following packages have unmet dependencies:
 ros-kinetic-realsense-camera : Depends: ros-kinetic-librealsense but it is not going to be installed

Next, you guessed it, I tried

sudo apt-get install ros-kinetic-librealsense

Surprise, surprise...

The following packages have unmet dependencies:
ros-kinetic-librealsense : Depends: linux-headers-generic but it is not going to be installed

Finally, one from the distro that will work!

sudo apt-get install linux-headers-generic

BUT! It's not THAT easy... You also need to enable the source repositories, since installing ros-kinetic-librealsense incurs a compilation which requires your kernel sources, so from the ROS docs, we can see how to do this, or you can copy me

sudo sh -c 'echo "deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted" > \
  /etc/apt/sources.list.d/official-source-repositories.list'
sudo apt-get update

Now, magic happens! (assuming you have typical compilers installed)

(Optional)

sudo apt-get install build-essential g++

Let's try this again

sudo apt-get install ros-kinetic-librealsense

It should build, you may see some warnings, but as long as it completes OK, you can continue back up out of the rabbit hole

sudo apt-get install ros-kinetic-realsense-camera
sudo apt-get install ros-kinetic-turtlebot

Yay! turtlebot on kinetic!

edit flag offensive delete link more

Comments

1

It would appear that your "Do this:" box of instructions is already a bit outdated. I just successfully followed all of your steps omitting sudo apt-get install -y ros-kinetic-librealsense-camera since this package no longer exists. But the ros-kinetic-turtlebot install worked anyway. Just FYI.

SeanTronathon gravatar imageSeanTronathon ( 2017-07-09 18:11:38 -0500 )edit

sudo apt-get install ros-kinetic-turtlebot* This works well for me on Ubuntu 16.04, ROS Kinetic. No further installation is required.

tranvannhancu gravatar imagetranvannhancu ( 2018-06-26 04:00:54 -0500 )edit
1

answered 2017-03-05 05:50:07 -0500

vegetish gravatar image

I got everything up and running with these scripts: https://bitbucket.org/damienjadeduff/...

edit flag offensive delete link more

Comments

Albeit some packages not working, like the dashboard.

vegetish gravatar imagevegetish ( 2017-03-05 13:58:17 -0500 )edit
0

answered 2016-10-21 16:24:05 -0500

homagni gravatar image

I could install ROS kinetic properly, but I am facing error in the source installation of turtlebot http://wiki.ros.org/turtlebot/Tutoria... At the first step in sudo apt-get install python-rosdep python-wstool ros-indigo-ros

I get the error: E: Unable to locate package ros-indigo-ros

Does anyone know of a way to solve this?

edit flag offensive delete link more

Comments

Use the kinetic version not the indigo version. See the comment on my answer.

tfoote gravatar imagetfoote ( 2016-10-24 12:29:57 -0500 )edit
0

answered 2017-08-09 02:44:53 -0500

Hello sir,

So sorry I am just a beginner. So this question maybe stupid. After this particular installation setup, how do I move forward with using Turtlebot. I tried: roslaunch turtlebot_gazebo turtlebot_world.launch

However, I get the error [turtlebot_world.launch] is neither a launch file in package [turtlebot_gazebo] nor is [turtlebot_gazebo] a launch file name

Thank you so much

edit flag offensive delete link more
0

answered 2017-03-25 10:47:28 -0500

I managed to get mine working on Ubuntu 16.04 LTS. I had a similar issue because I was using Anaconda :( I tried a bunch of solutions but the most recent one that worked was pip install defusedxml . I also did a bunch of wildcard installs sudo apt-get install ros-kinetic-turtlebot* and on "ros-kinetic-kobuki". Hope it solves your problem

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-10-19 13:42:53 -0500

Seen: 22,613 times

Last updated: Aug 09 '17