rosserial_mbed Publisher example

asked 2016-10-12 04:51:21 -0500

Zero gravatar image

Hi everyone,

I'm trying to study rosserial publisher example, but when I download the program to my mbed and run it. Its shows me follow error about: Tried to publish before configured, topic id 125 The follow will be the error photo: image description

The example link:http://wiki.ros.org/rosserial_mbed/Tutorials/Hello%20World

By the way, my computer is using ubutun 16.04 LTS and Kinetic, the imported lib was ros_lib_indigo. Does anyone met this error before? Thank you.

edit retag flag offensive close merge delete

Comments

Are you still having this issue? are you using rosserial_mbed from debians or did you install it via sources?

Gary Servin gravatar imageGary Servin ( 2016-11-10 10:48:57 -0500 )edit

I solved it

Zero gravatar imageZero ( 2016-12-30 02:28:32 -0500 )edit

Can you share how you solved it? thanks!

Gary Servin gravatar imageGary Servin ( 2016-12-30 20:28:21 -0500 )edit

what i had try is change the suitable lib then I try change the buff size in the lib

Zero gravatar imageZero ( 2017-01-10 04:38:46 -0500 )edit