"Could not find UUID" - error while installing bondcpp from source on Fedora 24

asked 2016-09-29 22:30:54 -0600

Willson Amalraj gravatar image

I am trying to install ros-indigo bondcpp package from source on Fedora 24. However the installation fails with the error

CMake Error at /home/xxx/catkin_ws/src/cmake_modules/cmake/Modules/FindUUID.cmake:41 (message):
Could not find UUID
Call Stack (most recent call first):
             CMakeLists.txt:6 (find_package)

I have installed the uuid-dev packages manually. I can see the header files in /usr/include directory and library files in /usr/lib64 directory.

I had also looked at this discussion. There seems to be an issue raised in bondcpp package in GitHub. That issue is marked as solved. But I am still getting the same error.

I have also tried to manually add the absolute paths in the FindUUID.cmake file

 find_path(UUID_INCLUDE_DIRS uuid/uuid.h
    /usr/include
    /usr/local/include)
 find_library(UUID_LIBRARIES 
    NAMES uuid
    PATHS /usr/lib64 /usr/local/lib)

But this also has not solved the problem. Any suggestion to solve this would be greatly helpful.

edit retag flag offensive close merge delete