Ask Your Question
0

buildfarm Krel_import-package checksum error

asked 2016-09-28 08:02:28 -0600

matlabbe gravatar image

updated 2016-09-28 08:03:55 -0600

Hi,

I got a lot of emails from the buildfarm concerning sourcedebs checksum errors:

File "pool/main/r/ros-kinetic-rtabmap/ros-kinetic-rtabmap_0.11.8.orig.tar.gz" is already registered with different checksums!
md5 expected: 43c514654a21568f838c575b3c0baba7, got: 64c9eb84ed9ba85b8cfe31f4eb4296c3
 sha1 expected: 3bfcda7c5e5bc44b8626e1c11a96f25ae95a27a8, got: 0000efe344bdce1d3c063627c77600da3194df6f
sha256 expected: e82ce0b2da9118a8e7a57aab87f757085b087937ca879a8c7d36c20ce1c8503a, got: 73353592d6dfa1eff800236cf96a115592565b7296ab2ec3c99ea5e505b0da84
size expected: 17606507, got: 17606597
There have been errors!

Example of the failing job's message:

Waiting for the completion of Krel_import-package
Krel_import-package #52328 completed. Result was FAILURE

Builds affected are:

http://build.ros.org/job/Ksrc_uX__rtabmap__ubuntu_xenial__source/
http://build.ros.org/job/Ksrc_uW__rtabmap__ubuntu_wily__source/

Repository: https://github.com/introlab/rtabmap-r...

Maybe related to:

Is this could be fixed just by redoing a bloom-release?

cheers,

Mathieu

edit retag flag offensive close merge delete

Comments

Just noticed ( https://github.com/ros-infrastructure... ) that my python-bloom version (0.5.20) was not the latest one (0.5.22). I just released again a new version, hope this will fix the problem.

matlabbe gravatar imagematlabbe ( 2016-09-28 08:39:03 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-09-28 13:03:46 -0600

tfoote gravatar image

I don't think it's the version of bloom that was the problem but that you retagged content before that release: https://github.com/ros/rosdistro/pull...

Changing tagged content violates assumptions that the build pipeline makes about data consistency. Version tagged content is not expected to change.

The rerelease probably cleared the cached content at some level.

edit flag offensive delete link more
0

answered 2016-09-28 11:12:10 -0600

matlabbe gravatar image

As referred in the first comment above, upgrading to python-bloom version 0.5.22 did solve the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-09-28 08:02:28 -0600

Seen: 67 times

Last updated: Sep 28 '16