error in : $ roslaunch diff_wheeled_robot_control keyboard_teleop.launch [closed]

asked 2016-09-13 14:09:25 -0600

zakizadeh gravatar image

updated 2016-09-13 14:11:22 -0600

when i run : $ roslaunch diff_wheeled_robot_control keyboard_teleop.launch

i have this error : ERROR: cannot launch node of type [diff_wheeled_robot_control/diff_wheeled_robot_key]: can't locate node [diff_wheeled_robot_key] in package [diff_wheeled_robot_control]

for solve this error i run this code : rosdep install --from-paths ~/catkin_ws/src --ignore-src --rosdistro=ROSDISTRO

and i have this error : ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: diff_wheeled_robot_gazebo: Cannot locate rosdep definition for [gazebo_ros_control] diff_wheeled_robot_control: Cannot locate rosdep definition for [joy]

how can i fix that error ??

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by zakizadeh
close date 2016-09-15 17:46:30.764866


I only delete the "joy" in CMake.list, The program will be run

ThiemPHAM gravatar image ThiemPHAM  ( 2016-11-16 15:14:22 -0600 )edit