Ask Your Question
0

A quetion from ROS noobie. Error in talker & listener configuration

asked 2016-08-29 07:42:40 -0600

Robotfreak gravatar image

updated 2016-08-29 09:36:37 -0600

gvdhoorn gravatar image

Learning ROS from Mastering ROS for Robotics Programming book from yesterday. Actually i struck up in configuring talker & listener.

Configuration & Errors as follows. I need some help to clear the error.

ROS Indigo Ubuntu 14.04

CATKIN_MAKE:

roos@roos-Inspiron-1520:~$ cd catkin_ws
roos@roos-Inspiron-1520:~/catkin_ws$ catkin_make mastering_ros_demo_pkg
Base path: /home/roos/catkin_ws
Source space: /home/roos/catkin_ws/src
Build space: /home/roos/catkin_ws/build
Devel space: /home/roos/catkin_ws/devel
Install space: /home/roos/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/roos/catkin_ws/build"
####
####
#### Running command: "make mastering_ros_demo_pkg -j2 -l2" in "/home/roos/catkin_ws/build"
####
roos@roos-Inspiron-1520:~/catkin_ws$ roscore
... logging to /home/roos/.ros/log/58f9d6ee-6de2-11e6-aed6-001d09bb3726/roslaunch-roos-Inspiron-1520-17202.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://roos-Inspiron-1520:38168/
ros_comm version 1.11.20

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES

auto-starting new master
process[master]: started with pid [17214]
ROS_MASTER_URI=http://roos-Inspiron-1520:11311/
setting /run_id to 58f9d6ee-6de2-11e6-aed6-001d09bb3726
process[rosout-1]: started with pid [17227]
started core service [/rosout]

WHILE RUNNING TALKER & LISTENER I AM GETTING FOLLOWING ERROR:

roos@roos-Inspiron-1520:~$ rosrun mastering_ros_demo_pkg demo_topic_publisher
[rospack] Error: package 'mastering_ros_demo_pkg' not found
roos@roos-Inspiron-1520:~$ 
roos@roos-Inspiron-1520:~$ rosrun mastering_ros_demo_pkg demo_topic_subscriber
[rospack] Error: package 'mastering_ros_demo_pkg' not found
roos@roos-Inspiron-1520:~$
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-08-29 10:12:46 -0600

bhavyadoshi26 gravatar image

Did you add the workspace to your ROS environment?

When you open a new terminal, try this first before running rosrun :

$ source ~/catkin_ws/devel/setup.bash
edit flag offensive delete link more
0

answered 2016-08-29 23:27:53 -0600

Robotfreak gravatar image

Thank you. it worked. Mistakes i did is i haven't used " $ source ~/catkin_ws/devel/setup.bash " command in all three shells ( i.e, in master shell , talker shell and listener shell ). It's must to run setup.bash each and every time?? there is no auto run option??

Now i am getting an error called " Executable are not found " . Found solution in ROS forum. I have to go through the forum to clear the error " executable are not found ".

edit flag offensive delete link more

Comments

Can you please post the "Executable not found" as another question to avoid confusion?

bhavyadoshi26 gravatar imagebhavyadoshi26 ( 2016-08-30 03:20:20 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-29 07:42:40 -0600

Seen: 68 times

Last updated: Aug 29 '16