Ask Your Question
0

rviz screen problem

asked 2016-07-30 03:23:30 -0500

Ghazal gravatar image

updated 2016-07-30 13:53:38 -0500

hello,

I'm working with rviz and when I run rosrun rviz rviz I get the screen like this. I searched a lot and I tried several solutions but none helped.

I'm using NVIDIA C61 [GeForce 7025 / nForce 630a] graphics card with nvidia-304 driver installed. I also use ubuntu 14.04 and ROS indigo 1.11.20.

any suggestions would be highly appreciated.

thank you in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-30 08:58:33 -0500

kramer gravatar image

It looks like a default RViz screen to me...are you sure there's a problem?

You might need to set a robot state publisher or other information sources, then select and/or set up appropriate displays/panels...

edit flag offensive delete link more

Comments

thank you for your reply.

if you take a look at these photos you will get what my problem is. guess the previous video was not in a good quality!

link textlink text

Ghazal gravatar image Ghazal  ( 2016-07-30 14:00:55 -0500 )edit

I can't make out the contents of those images. The resolution is fine (about 1080 x X), but it looks like the scan lines are interleaved. Can you just do a screen capture rather than taking a picture of the screen? (Try the 'screenshot' program.)

kramer gravatar image kramer  ( 2016-07-31 09:26:20 -0500 )edit

"you will get what my problem is" or... you just explain it yourself.

NEngelhard gravatar image NEngelhard  ( 2016-07-31 11:21:37 -0500 )edit

I didn't know how to explain my problem that's why I used photos. the problem is exactly what you said! when I run rviz it looks like the scan lines are interleaved and the colors are mixed some how. at first I tried the screenshot program but the output is just a black screen that can't be opened.

Ghazal gravatar image Ghazal  ( 2016-07-31 23:46:28 -0500 )edit

and the point is that all my screen becomes like this not only the rviz window and I have to restart my pc to get the screen back and be able to use it again.

Ghazal gravatar image Ghazal  ( 2016-07-31 23:48:21 -0500 )edit
1

Ah. That seems like less of a ROS problem and more of a graphics card issue. But I don't know and it's out of my general knowledge area. Sorry, hope someone else can help...

kramer gravatar image kramer  ( 2016-08-01 08:29:16 -0500 )edit

yeah I think the problem is with my graphics card as well but I only have this problem with rviz. by the way, thank you :)

Ghazal gravatar image Ghazal  ( 2016-08-01 15:06:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-30 03:23:30 -0500

Seen: 666 times

Last updated: Jul 30 '16