ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

install ros on odroid c2 running Ubuntu 16.04

asked 2016-07-25 10:49:07 -0500

audia8.sid gravatar image

Hello community, I'm trying to install ROS Kinetic on ODROID C2 running Ubuntu 16.04 but am facing some errors while running the rosdep command. I also tried the source installation but no luck! The wiki page I followed - [ http://wiki.ros.org/kinetic/Installat... ] I had problems with the qtbase5 dependency installation. So, I tried installing QT5 separately but that too didn't work. I want to install MAVROS on ODROID C2. So, any help on this would be really appreciated. Tried looking at all the wiki pages possible but couldn't find a solution. Saw others also facing the same problem!

Thanks in advance

edit retag flag offensive close merge delete

Comments

Which step gave which error? Could you post the specific messages?

neuronet gravatar image neuronet  ( 2016-07-25 11:32:41 -0500 )edit

Have you seen this: http://wiki.ros.org/indigo/Installati... I'm not sure Kinect is there yet. See http://answers.ros.org/question/18747... and perhaps http://answers.ros.org/question/23525... . I'm a noob and not ARM-user--good luck.

neuronet gravatar image neuronet  ( 2016-07-25 11:37:22 -0500 )edit
1

Thanks for the info. I followed to steps to install ROS Indigo for Debian and somehow it worked! Thank you so much for the links.. <cheers>

audia8.sid gravatar image audia8.sid  ( 2016-07-25 23:23:55 -0500 )edit

That's good, and it's supported through 2019..I would suggest, whatever you did (even if it is to just follow the instructions at that link) that you turn it into an answer and accept it.

neuronet gravatar image neuronet  ( 2016-07-26 08:00:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-26 21:34:15 -0500

audia8.sid gravatar image

I followed the instructions to install ROS Indigo for Debian and it worked fine on the ODROID C2 [Ubuntu 16.04 Xenial] [link text](http://wiki.ros.org/indigo/Installation/Debian "ROS Indigo Debian")

But finally I wanted to install mavros on it and could not complete that one! So, if anyone has done it or has any idea please help me out! Thanks

edit flag offensive delete link more

Comments

Did you ever get mavros working? I need to get a C2 setup with mavros if it's possible. Using Ubuntu 16.04 with Indigo seems like it could cause a lot of issues, so I haven't tried yet.

Sam94 gravatar image Sam94  ( 2016-08-07 22:14:59 -0500 )edit

Yes indeed! I installed ROS Kinetic and then got the MAVROS working on the C2 with some twitches in the installation.

audia8.sid gravatar image audia8.sid  ( 2016-08-10 23:38:15 -0500 )edit

How did you install Kinetic? I tried a couple of methods and kept running into dependency issues. If you get a chance, can you please post a solution? Thanks.

Sam94 gravatar image Sam94  ( 2016-08-11 10:14:42 -0500 )edit

Yea, if you directly follow the steps you get dependency issues. So, for that I removed a package mali-X11, installed qt5-default and then installed ROS. After that, I reinstalled mali-X11 and was able to run roscore. Detailed steps

audia8.sid gravatar image audia8.sid  ( 2016-08-12 01:44:09 -0500 )edit

Thanks, I got it installed about a week ago. As a quick addendum, this has to be done on a fresh installation of Ubuntu, if you try it after using 'apt-get dist-upgrade' you won't be able to access the necessary packages.

Sam94 gravatar image Sam94  ( 2016-08-31 21:05:53 -0500 )edit

OK great! Thanks for the info and cool you got it working.

audia8.sid gravatar image audia8.sid  ( 2016-09-01 06:54:42 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-07-25 10:49:07 -0500

Seen: 2,237 times

Last updated: Jul 26 '16