Issue with usb_cam: select timeout yuyv usb_cam package

asked 2016-07-16 16:56:54 -0500

pedro_abreu gravatar image

Hello, so my issue has to do with the yuyv pixel format in the usb_cam package. My launch file and everything works well with mjpeg and I can't understand why. I have installed and reinstalled OpenCV twice now (I'm running Ubuntu 14.04.4), from compiling the source code AND from script(repositories) and two different versions. Whenever I launch my launch file (with yuyv pixel format), the image halts, gets chopped up like this and I get:

[ERROR]: select timeout

And then the process dies. I've also installed the perception ROS package for image processing. Here is my launch file

<launch>
  <node name="usb_cam" pkg="usb_cam" type="usb_cam_node" output="screen" >
    <param name="/dev/video0" value="/dev/video0" />
    <param name="image_width" value="640" />
    <param name="image_height" value="480" />
    <param name="pixel_format" value="yuyv" />
    <param name="camera_frame_id" value="usb_cam" />
    <param name="io_method" value="mmap"/>
    <param name="framerate" value="60"/>
    <param name="sharpness" value="255"/>
    <param name="contrast" value="30"/>
    <param name="brightness" value="0"/>
    <param name="saturation" value="50"/>
  </node>
  <node name="image_view" pkg="image_view" type="image_view" respawn="false" output="screen">
    <remap from="image" to="/usb_cam/image_raw"/>
    <param name="autosize" value="true" />
  </node>
</launch>

Is this some sort of problem with the buffer size since the resolution is too high? Maybe the framerate is too high? I've changed both to half and saw no results so I don't think that's it. I've been looking around but most people seem to have issues with select timeout all around, not just on one pixel format.

Thank you

edit retag flag offensive close merge delete

Comments

Hi guy, I meet the same question what you met and I have no idea about that. Have you delt with it successfully?

YancenBOB gravatar imageYancenBOB ( 2019-08-07 03:43:49 -0500 )edit