Ask Your Question
2

E: Unable to locate package ros-kinetic-desktop-full

asked 2016-05-27 11:52:30 -0500

dolphin123 gravatar image

Is ros-kinetic-desktop-full available? I have followed the steps from http://wiki.ros.org/kinetic/Installat... but keep getting the error E: Unable to locate package ors-kinetic-desktop-full when I enter sudo apt-get install ros-kinetic-desktop-full

Also if I try to click on the link given on the installation page where it says "or click here" the link fails.

edit retag flag offensive close merge delete

Comments

It should be available, yes. See status_page/ros_kinetic_default.html?q=desktop. That is for x86/64 though, and you don't tell us your architecture / platform.

gvdhoorn gravatar imagegvdhoorn ( 2016-05-27 12:39:59 -0500 )edit
1

@dolphin123, did Step 1.2 succeed? Did you do sudo apt-get update as instructed in Step 1.4? Also, keep in mind that "ROS Kinetic ONLY supports Wily (Ubuntu 15.10), Xenial (Ubuntu 16.04) and Jessie (Debian 8) for debian packages."

spmaniato gravatar imagespmaniato ( 2016-05-27 14:19:35 -0500 )edit

I am using a 64-bit PC with Ubuntu 16.04. Step 1.2 succeeded and I updated, but I still get the error above that the kinetic desktop full package cannot be located.

dolphin123 gravatar imagedolphin123 ( 2016-05-27 16:28:36 -0500 )edit

Does apt-cache search ros-kinetic find anything at all?

spmaniato gravatar imagespmaniato ( 2016-05-27 17:07:50 -0500 )edit

In my case apt-cache search ros-kinetic produced a long list which included ros-kinetic-desktop but not ros-kinetic-desktop-full which apparently is not included in the download from http://packages.ros.org/ros/ubuntu . Installing per the second option in step 1.4 worked fine.

rospiguy gravatar imagerospiguy ( 2016-09-27 09:21:25 -0500 )edit

As my platform is Ubuntu Trusty(14.04), only Indigo Igloo and Jade Turtle work for me. When I tried to install ros-kinetic-desktop-full, it reported the error as yours.

The complete list of target platform and ros version is at http://www.ros.org/reps/rep-0003.html... .

yuxwind gravatar imageyuxwind ( 2018-05-24 18:38:45 -0500 )edit

I tried installing ROS and got the same error running Ubuntu 16.04.6 LTS. I tried everything mentioned here , but it ain't working

babayaga gravatar imagebabayaga ( 2019-03-13 11:14:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-01-08 04:53:55 -0500

Lex gravatar image

I had a similar issue, the problem for me was that I did not run apt-get update after setting up the ros sources.list and keys.

running sudo apt-get update after setting up the sources and keys downloaded the following packages:

Get:8 http://packages.ros.org/ros/ubuntu xenial InRelease [4,025 B]
Get:9 http://packages.ros.org/ros/ubuntu xenial/main armhf Packages [245 kB]

Running the following install command after that worked fine:

sudo apt-get install ros-kinetic-desktop-full
edit flag offensive delete link more

Comments

Thanks a lot! this works, following steps in http://wiki.ros.org/kinetic/Installat... .

Haifei gravatar imageHaifei ( 2017-12-31 00:37:01 -0500 )edit
1

answered 2016-06-03 12:24:18 -0500

JamesWell gravatar image

"E: Unable to locate package ors-kinetic-desktop-full", didn't you just mistype 'ros'?

edit flag offensive delete link more

Comments

Hi,my source list is fine but still got error on a pi 3: When "sudo apt-get update", it hit packages.ros.org jessie InRelease, and jessie/main armhf Packages, etc. But "apt-cache search ros-kinetic" gave error; or even "ros" returned nothing. I could install from src, but wonder if I did wrong. thks

kc2 gravatar imagekc2 ( 2016-08-10 20:53:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-05-27 11:52:30 -0500

Seen: 41,394 times

Last updated: May 24 '18