Ask Your Question
0

Parameters do not updated until I rerun roscore

asked 2016-05-23 08:55:01 -0500

MariaKrgr gravatar image

Hello there, I use navigation stack and nav2d (I hope, that's something irrelevant) and when I change a parameter inside a .yaml file, I also need to rerun roscore so that the new parameter takes effect.

Any ideas what's wrong?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-05-23 09:54:53 -0500

dornhege gravatar image

You don't need to start roscore, in fact that will reset all parameters.

However, you need to restart something that loads these parameters. Probably one of your launch files will read the yaml and load the parameters from there.

edit flag offensive delete link more

Comments

I re-launch my launch file that runs all relative nodes and the parameters are not being updated until I re-run roscore..

MariaKrgr gravatar imageMariaKrgr ( 2016-05-25 10:05:26 -0500 )edit

A launch file that starts nodes needs a roscore, re-starting a roscore that has been running before sounds like something will go wrong. If no roscore is running the roslaunch will also start one on its own. You should never (need to) restart a roscore that has been running without restarting all.

dornhege gravatar imagedornhege ( 2016-05-27 06:48:57 -0500 )edit

Ok today updating parameters works for some magic reason.. Thank you for your time

MariaKrgr gravatar imageMariaKrgr ( 2016-05-27 07:09:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-23 08:55:01 -0500

Seen: 142 times

Last updated: May 23 '16