Maxon motor with ROS

asked 2016-04-24 02:50:15 -0500

Ros_user gravatar image

updated 2016-04-24 02:52:39 -0500

I have just bought a MCD EPOS Maxon Motor and I would like to run it with ROS. I have used this package, and whenever I try to run

roslaunch epos_hardware example.launch

it gives me this error:

started core service [/rosout]
process[epos_hardware-2]: started with pid [15836]
process[controller_spawner-3]: started with pid [15853]
[ERROR] [1461483492.673722502]: Could not find motor
[ERROR] [1461483492.673804000]: Not Initializing: 0x60002998
[ERROR] [1461483492.673939563]: Could not configure motor: my_joint_actuator
[FATAL] [1461483492.673989258]: Failed to initialize motors

My device's serial number is 0x60002998. I have also tried with what the answer for this question suggests and I have also given permission to all usb. I'm using a Ltd FT232 USB-Serial.

The only different thing I have from the previous question's author is that I'm using the last version of EPOS (MCD), but I think they work in the same way.


edit retag flag offensive close merge delete


Have you solved your Problem? I have also problems with epos_hardware :/

Milliau gravatar image Milliau  ( 2016-08-10 03:38:33 -0500 )edit