ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosserial AVR cannot conneted to the computer

asked 2016-04-16 16:57:12 -0500

Jayantha gravatar image

I am new to ros. I running ROS Indio on Ubuntu version 14. I tried ROS serial Arduino Hello World program with Promini boad with FTDI module and with Arduino Uno. To my surprise when I unplug and plug Pro mini board, program works perfectly, but with Arduino Uno it works only once.If it is unplugged and plugged it gives error as cannot synchronies.

Computer has to be restated for Arduino Uno board to sync and run the program. Both boards are having same ATmega 328P chips. Same program is running on both. Only difference is FTDI module connected externally for Pro Mini board and for Arduino Uno it is On the same board.

I followed Ros Serial Avr Usart Tutorial and followed all the steps. I am using similar Pro Mini board for avr tutorial as well . On board crystal is 16 MHz. When I connected with USB-TTL module I am getting the same error as cannot synchronies. I need help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-04-17 06:18:37 -0500

duck-development gravatar image

The Problem is that if you disconnect the USB plug the USB UART (ftdi) Linux driver try to free the device Handel, but if the file handle is opened from pyserial, it can not be done properly. So one solution could be to shutdown the rosserial nodes best before the disconnect. And then run the nodes after a short time you reconneced the USB device. And you have to connect the device in the same USB plug as it was before.

edit flag offensive delete link more


Thank you very much for your answer. But the error still persistent.

Jayantha gravatar image Jayantha  ( 2016-04-17 07:39:31 -0500 )edit

Question Tools


Asked: 2016-04-16 16:57:12 -0500

Seen: 178 times

Last updated: Apr 17 '16