Ask Your Question
0

Cmake Error when installing

asked 2016-04-04 12:18:19 -0500

kuljotdhami gravatar image

Hey guys I am attemping to source and install a autonomous navigating robot project built on ros indigo and found at this link

https://github.com/sungjik/my_personal_robotic_companion

I follow the following instructions to install and source into a catkin ws.

cd ~

mkdir -p catkin_ws/src

Then check out the package into it:

cd ~/catkin_ws/src git clone https://github.com/sungjik/my_persona...

Install dependencies:

cd ~/catkin_ws rosdep install --from-paths src -i -y

(If rosdep still reports missing dependencies, check their source out into your workspace too)

And finally, build and source your workspace:

cd ~/catkin_ws catkin_make source devel/setup.bash

As soon as I run catkin_make its working for a few seconds then near the end I get the following error - +++ processing catkin package: 'my_personal_robotic_companion' -- ==> add_subdirectory(my_personal_robotic_companion/my_personal_robotic_companion) -- Using these message generators: gencpp;genlisp;genpy CMake Error at /opt/ros/indigo/share/catkin/cmake/catkin_package.cmake:296 (message): catkin_package() include dir 'include' does not exist relative to '/home/kuljot/catkin_ws/src/my_personal_robotic_companion/my_personal_robotic_companion' Call Stack (most recent call first): /opt/ros/indigo/share/catkin/cmake/catkin_package.cmake:98 (_catkin_package) my_personal_robotic_companion/my_personal_robotic_companion/CMakeLists.txt:86 (catkin_package)

-- Configuring incomplete, errors occurred! See also "/home/kuljot/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/kuljot/catkin_ws/build/CMakeFiles/CMakeError.log". make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed kuljot@kuljot-Lenovo-IdeaPad-U530-Touch:~/catkin_ws$

The link to the cmakelists.txt fille is below

https://github.com/sungjik/my_persona...

Can someone please help me debug what is wrong. I know other people online have been able to launch this project but I have no way of contacting them to see if they had to fix any issues with this.

Thanks!!

edit retag flag offensive close merge delete

Comments

hello, i experience the same problem and couldn't really understand the answer that ahendrix given, could you please tell me how i can create an empty include directory in the my_personal_robotic_companion package or which line should i delete in the CMakeLists ( and which CMakeList)? thx

dana.dhanugraha gravatar image dana.dhanugraha  ( 2016-12-31 01:08:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-04-04 12:37:43 -0500

ahendrix gravatar image

The catkin_package call at https://github.com/sungjik/my_persona... specifies that the include directory should be exported to downstream packages, and the cmake error is telling you that that directory does not exist.

You could either try to delete the line that references the include directory from the CMakeLists, or you could create an empty include directory inside the my_personal_robotic_companion package.

edit flag offensive delete link more

Comments

Thank you that worked. I have one more small issue. Everything launches perfectly one. Then when I try to launch it again it acts like my_personal_robotic_companion is not installed using rospack find command. Randomly it works and randomly it think I dont have the package installed. Any thoughts?

kuljotdhami gravatar image kuljotdhami  ( 2016-04-04 13:03:21 -0500 )edit

Each time you open a new shell (terminal) you need to source your workspace again. You can also add the source command to your ~/.bashrc so that it runs for each new shell.

ahendrix gravatar image ahendrix  ( 2016-04-04 13:08:02 -0500 )edit

Thank you for your help brother.

kuljotdhami gravatar image kuljotdhami  ( 2016-04-04 13:20:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-04 12:18:19 -0500

Seen: 1,090 times

Last updated: Apr 04 '16

Related questions