Ask Your Question
0

E: Unable to locate package ros-indigo-ros-tutorials

asked 2016-03-30 00:19:23 -0500

GarethZhang gravatar image

I just installed ros indigo on my raspberry pi following this tutorial: http://wiki.ros.org/ROSberryPi/Instal...

Now I am trying to go over some beginner level tutorials following this link: http://wiki.ros.org/ROS/Tutorials/Nav...

I kept getting errors when I was trying to install ros tutorials. E: Unable to locate package ros-indigo-ros-tutorials

Does anyone know what to do?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-03-30 02:54:08 -0500

Mehdi. gravatar image

updated 2016-03-30 02:55:34 -0500

I guess you are not using Ubuntu on your raspberry Pi but Raspbian. If it is the case, it might be that they are not available as deb packages. What you should do is cloning them from the Github repository and compiling them in your workspace using Catkin. This tutorial explains how to use a catkin workspace.

edit flag offensive delete link more

Comments

Hi, yes I am using Raspbian. I followed your comment and used git clone under the directory ~/ros_catkin_ws/. Then how can I compile those files in my workspace using Catkin? Should I build a package using catkin_make according to the link you attached?

Sorry if these questions are too stupid...

GarethZhang gravatar image GarethZhang  ( 2016-03-31 01:12:28 -0500 )edit

yes go to the root of your workspace (here cd ~/ros_catkin_ws ) and run catkin_make

Mehdi. gravatar image Mehdi.  ( 2016-03-31 02:50:07 -0500 )edit

Great! Thanks!

GarethZhang gravatar image GarethZhang  ( 2016-03-31 19:07:37 -0500 )edit

Hi, I ran catkin_make in my workspace successfully without errors. But after all, as I run sudo apt-get install ros-indigo-ros-tutorialsI get the same error message. There is a ros_tutorials folder in my workspace, and also a ros_tutorial package within the folder. Did I do something else wrong?

GarethZhang gravatar image GarethZhang  ( 2016-04-05 19:56:46 -0500 )edit

I think you have a understanding problem with how in general software is installed in Linux. Once you compile a program from source (here with catkin_make) there is no need to install it using apt-get. Just make sure that your workspace is listed in the ROS path, this can be done

Mehdi. gravatar image Mehdi.  ( 2016-04-06 03:39:50 -0500 )edit

by running source your_workspace/devel/setup.bash

Mehdi. gravatar image Mehdi.  ( 2016-04-06 03:40:31 -0500 )edit

Thanks it works! I am a beginner with Linux :) Thx for teaching!

GarethZhang gravatar image GarethZhang  ( 2016-04-06 11:20:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-30 00:19:23 -0500

Seen: 1,810 times

Last updated: Mar 30 '16