Ask Your Question
0

catkin_make error when using vrpn_client_ros

asked 2016-02-21 20:40:40 -0500

Shusen gravatar image

Hi, I want to connect Optitrack and ROS together, using the package vrpn_client_ros. Now, I'm using ubuntu14.04 installed ros indigo. I found the package from http://wiki.ros.org/vrpn_client_ros and git clone the code form https://github.com/clearpathrobotics/... into my folder ~/catkin_ws/src. but when I run

catkin_make

,

it came to errors like ths:

> CMake Error at
> vrpn_client_ros/CMakeLists.txt:5
> (find_package):   By not providing
> "FindVRPN.cmake" in CMAKE_MODULE_PATH
> this project has   asked CMake to find
> a package configuration file provided
> by "VRPN", but   CMake did not find
> one.
>
>   Could not find a package
> configuration file provided by "VRPN"
> with any of   the following names:
>
>     VRPNConfig.cmake
>     vrpn-config.cmake
>
>   Add the installation prefix of
> "VRPN" to CMAKE_PREFIX_PATH or set  
> "VRPN_DIR" to a directory containing
> one of the above files.  If "VRPN"  
> provides a separate development
> package or SDK, be sure it has been  
> installed.
>
>
> -- Configuring incomplete, errors occurred! See also
> "/home/sen/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also
> "/home/sen/catkin_ws/build/CMakeFiles/CMakeError.log".
> Invoking "cmake" failed

Why this happen? What should I do next? I will appreciate if you could help. Thanks a lot!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-02-22 01:19:53 -0500

paulbovbel gravatar image

You are missing the vrpn dependency for the package.

You could install all dependencies for your workspace via rosdep (rosdep install --from-paths .)

Or you could just install debians, which will pull in dependencies automatically (sudo apt-get install ros-indigo-vrpn-client-ros). Is there a reason you want to run from source?

edit flag offensive delete link more

Comments

Thanks a lot! It works. I want to connect Optitrack and ROS together, and then connect to pixhawk, then fly quadrotor indoors, I don't know what to do next. Can you give me some advice?

Shusen gravatar imageShusen ( 2016-02-22 01:43:41 -0500 )edit

I have kind of similar problem I tried to run catkin_make after cloning to catkin_ws and exporting it but I received this error

Running command: "make cmake_check_build_system" in "/home/kidus/catkin_ws/build"

UbuntuROs gravatar imageUbuntuROs ( 2017-06-26 12:11:59 -0500 )edit

Hi Paul, I am using ros lunar and met this error. I copied the source package into my workspace and catkin_make, the same error occurs. I tried to install the VRPNConfig.cmake vrpn-config.cmake related package/library, but failed. DO you have any idea to solve this?

jason gravatar imagejason ( 2017-08-28 21:47:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-21 20:40:40 -0500

Seen: 1,096 times

Last updated: Feb 22 '16