Ask Your Question
0

RGBDSLAM make problem: /usr/bin/ld: cannot find -lrgbdslam

asked 2016-02-05 00:21:15 -0500

tango_explorer gravatar image

I managed to get rgbdslamv2 to work on ros but wasn't satisfied with the result I was getting so I decided to use icp in the compilation process by setting the following variables :

set(USE_GICP_BIN 0)

set(USE_GICP_CODE 1)

set(USE_PCL_ICP 1)

This almost worked but I ran into a problem and had to reset the build path by doing

SET(gicp_build_path ${CMAKE_SOURCE_DIR}/felixendres-rgbdslam_v2-f7efd5b/external/gicp/ann_1.1.2)

instead of

SET(gicp_build_path ${CMAKE_SOURCE_DIR}/external/gicp/ann_1.1.2)

because for some reason this is how the folders are set up on my computer and everything seems to work fine until I run into the error:

/usr/bin/ld: cannot find -lrgbdslam

I am not sure what is going on and I'm kind of new to all this. Can someone help? Also, all the editing was done only in the cmakelists.txt file

This is the output from my terminal:

ee125@ee125-vm:~$ cd ./rgbdslam_catkin_ws/

ee125@ee125-vm:~/rgbdslam_catkin_ws$ catkin_make

Base path: /home/ee125/rgbdslam_catkin_ws

Source space: /home/ee125/rgbdslam_catkin_ws/src

Build space: /home/ee125/rgbdslam_catkin_ws/build

Devel space: /home/ee125/rgbdslam_catkin_ws/devel

Install space: /home/ee125/rgbdslam_catkin_ws/install ####

Running command: "make cmake_check_build_system" in "/home/ee125/rgbdslam_catkin_ws/build"

#### ####

Running command: "make -j3 -l3" in "/home/ee125/rgbdslam_catkin_ws/build"

####

[ 8%] [ 15%] Linking CXX shared library ../devel/lib/libgicp.so

Built target rgbdslam_generate_messages_py

Built target rgbdslam_generate_messages_cpp

[ 22%] Built target rgbdslam_generate_messages_lisp

[ 22%] Built target rgbdslam_gencpp

[ 22%] Built target rgbdslam_generate_messages

/usr/bin/ld: cannot find -lrgbdslam

collect2: ld returned 1 exit status

make[2]: * [devel/lib/libgicp.so] Error 1

make[1]: * [felixendres-rgbdslam_v2-f7efd5b/CMakeFiles/gicp.dir/all] Error 2

make: * [all] Error 2

Invoking "make" failed

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-05 11:26:05 -0500

Unfortunately GICP is not supported anymore in rgbdslam_v2, so this won't be the only problem you need to fix. GICP inclusion is a remnant of a former colleagues work and would probably need quite some work to be made functional again.

You might try only USE_PCL_ICP, but I'd guess it might also be buggy.

Anyway, in my experiments, (G)ICP resulted in deviations more often than in improvements (which ought to be scenario-specific though).

edit flag offensive delete link more

Comments

Thanks Felix! One more question. I got rgbdslam to work for my application by recording the files listed here: link text apart from /tf. Is /tf for the case where the camera position changes wrt the robot position over time?

tango_explorer gravatar image tango_explorer  ( 2016-02-05 14:00:02 -0500 )edit

Yes, that was the intention. I haven't tested this in a long time though.

Felix Endres gravatar image Felix Endres  ( 2016-02-09 05:53:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-02-05 00:21:15 -0500

Seen: 210 times

Last updated: Feb 05 '16