Problem with keyboard_teleop in ROS by Example

asked 2016-01-28 07:24:01 -0500

rubber bread gravatar image

I learnt ROS By Example recently,and I have some problem with keyboard_teleop.launch

roslaunch rbx1_nav keyboard_teleop.launch

The launch file:


  <node pkg="turtlebot_teleop" type="turtlebot_teleop_key" name="turtlebot_teleop_keyboard" output="screen">
    <param name="scale_linear" value="0.1" type="double"/>
    <param name="scale_angular" value="0.4" type="double"/>
    <remap from="turtlebot_teleop_keyboard/cmd_vel" to="cmd_vel" />


However , I run this launch ,the terminal shows

ERROR: cannot launch node of type [turtlebot_teleop/turtlebot_teleop_key]: can't locate node [turtlebot_teleop_key] in package [turtlebot_teleop]

Before I run this launch ,I run

roslaunch rbx1_bringup fake_turtlebot.launch
rosrun rviz rviz -d `rospack find rbx1_nav`/sim.rviz

How to fix it?


edit retag flag offensive close merge delete


Hello. I am also facing the same problem "ERROR: cannot launch node of type [turtlebot_teleop/turtlebot_teleop_key]: turtlebot_teleop" in ROS kinetic, Ubuntu 16.04. Please help me, if you have found the solution. Thanks.

Mifta gravatar image Mifta  ( 2018-02-19 04:44:19 -0500 )edit